Error locating dictionaries

3 posts, 0 answers
  1. Ed
    Ed avatar
    24 posts
    Member since:
    May 2005

    Posted 02 Apr 2012 Link to this post

    Hi guys,

    I'm currently getting the following error when attempting to use the RadSpellChecker in my website

    Cannot read the configuration/dictionary language parameters!

    Stack Trace:


    [ArgumentException: Cannot read the configuration/dictionary language parameters!]

       Telerik.Web.UI.SpellCheckHandlerNoSession.ProcessRequest(HttpContext context) +628

       System.Web.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +100

       System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +75

    The dictionaries are in the correct place /App_Data/RadSpell, although deleting that folder doesn't seem to make any difference, and I am not setting the dictionary path differently anywhere else, and even if I do set the Dictionary Path explicitly I get the same error. Can you help?


  2. Rumen
    Rumen avatar
    14459 posts

    Posted 03 Apr 2012 Link to this post


    Please, see the following forum thread on the subject: Cannot read the configuration/dictionary language parameters!.

    This exception would occur in a scenario when the spell window performs a postback, sending the text to be spellchecked to the server. On the server, the SpellCheckHandler HTTP handler tries to read information about the language to be used for spellchecking and some additional information from the POST array.

    For some unknown reason (we are not sure which) this information is missing.
    One possibility is to use Fiddler and/or FireBug to examine the information in the Request object when the Spell Dialog makes the request. Perhaps the information there can provide some clues why the DictionaryLanguage or Configuration POST variables are empty.

    There could be something in your Web.config or your application setup that messes things up.

    In case you are not able to resolve the issue, we ask you to send us a simple project that reproduces the problem - then we will find out what is causing it.

    All the best,
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  3. Ed
    Ed avatar
    24 posts
    Member since:
    May 2005

    Posted 03 Apr 2012 Link to this post

    Problem solved - my application was converting the App_Data/RadSpell directory path to lower case and this was causing the dictionaries to not be found.
Back to Top