Error loading Configuration file in Rad Editor

3 posts, 0 answers
  1. Virgil Carroll
    Virgil Carroll avatar
    3 posts
    Member since:
    Dec 2005

    Posted 20 Jun 2007 Link to this post

    I just added the RadEditor for MOSS 2007 to our installation to demo for a client that may want to purchase.  The install worked fine but every time I tried to load up the control I get an:


    Server Error in '/' Application.

    Error opening Configuration File.

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: Telerik.WebControls.RadEditorUtils.InvalidConfigFileException: Error opening Configuration File.

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [InvalidConfigFileException: Error opening Configuration File.]
       Telerik.WebControls.RadEditor.GetValidConfigFile() +90
       Telerik.WebControls.RadEditor.ProcessConfigFile() +4197
       Telerik.WebControls.RadEditor.set_ConfigFile(String value) +48
       Telerik.WebParts.Editor.Dialogs.ContentEditor.Page_Load(Object sender, EventArgs e) +251
       System.Web.UI.Control.OnLoad(EventArgs e) +99
       System.Web.UI.Control.LoadRecursive() +47
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1061

    I have tried adding a reference to the ConfigFile.xml in the ContentEditor.aspx page, but this did not help.  I am hoping to demo this today, so any help is greatly appreciated.
  2. Lini
    Lini avatar
    2148 posts

    Posted 21 Jun 2007 Link to this post


    This error means that the ASP.NET user (Network Service) cannot find the ConfigFile.xml or ListConfigFile.xml. These files are located by default at: 
    \Program Files\Common Files\Microsoft Shared\web server extensions\wpresources\RadEditorSharePoint\\RadControls\Editor\.

    If the files are not there, then you might have a corrupt installation and I suggest that you retract the editor solution and try to deploy it again.

    If the files are there, then you have a problem with file permissions. Make sure that the ASP.NET user has at least read rights on the editor folder.

    All the best,
    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Mathis Marugg
    Mathis Marugg avatar
    6 posts
    Member since:
    Feb 2006

    Posted 14 Apr 2008 Link to this post

    The same error message may also appear when you upgrade to a new version and you've still referenced the old dll in for example your c# control (happend to me and I was looking at the rights for some time :))

    Reference to new one, recompile and gone is the error.
Back to Top