Error Creating Control solution found!

7 posts, 0 answers
  1. King Wilder
    King Wilder avatar
    240 posts
    Member since:
    Oct 2007

    Posted 17 Jan 2012 Link to this post

    I just found this nasty error this morning, for what seemed like no reason.  And I found a solution that worked for me, but it might not be readily available to fix for everyone, I'll explain.

    I've attached two screenshots, a before and after that displays my Visual Studio 2010 Design Views with the errors and the fixed result.

    The part that helped me figure it out was with the RadScheduler.  It displayed a much more helpful message that helped me find the solution.

    If you notice in the "error" screen shot the RadTreeView and RadMenu controls do not display anything but the error message.  But when I dragged a RadScheduler on the page, it displayed a much more helpful message. 

    Since I had just upgraded my ASP.NET AJAX controls to the latest version yesterday, the local cached version was still the prior version. This is what caused the errors.

    So here's what I did:
    1. Close Visual Studio
    2. Navigate to the location of the older Telerik assembly
    3. Delete it
    4. Open Visual Studio - and everything works!


    If you don't see a message that shows the path of the problem assembly, try dragging a RadScheduler onto the page to see if that shows the details paths.

    Edit - 1/23/2012
    This problem seemed to persist in later days, and I finally found a good work around.  In your web.config, you need to change this...

            <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI" />

    ... to this.

            <add tagPrefix="telerik" namespace="Telerik.Web.UI" assembly="Telerik.Web.UI, Version=2011.3.1305.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4" />

    Remember to change the version number to the version you have installed in your application.

    This works, but it does mean that you will have to manually update the version number if you ever upgrade your application in the future, but at least it will not generate all those errors.

    If anyone has a better solution, I would love to hear it.

    I hope this helps.


    King Wilder

  2. King Wilder
    King Wilder avatar
    240 posts
    Member since:
    Oct 2007

    Posted 26 Jan 2012 Link to this post

    This is follow up to explain that my previous solution, did NOT completely fix my issues.  This doesn't mean that it won't work for you, but in my case, it didn't and I'll explain why.

    My Solution
    At first I thought it had worked, but when I closed and re-opened the solution, the web app still showed those "error creating control" errors in design view.

    The reason had to do with the AppDomain.  It's explained in the last response in this post,

    It talks about the problems of having two different Telerik assembly versions in the same VS solution, since VS runs under a single AppDomain.

    In my situation I had started a RadControls web app with one version, then found out an uprgade was available and then I upgraded that app.  Everything still worked fine on that application, but I decided to change the way I was building the web app.  And instead of deleting everything I had done, I decided to just add a new RadControls web app, but this time it would be started with the latest Telerik assembly.

    My second web app started showing those "error creating control" errors in design view right off the bat, and I couldn't figure out why.

    Then I read that post about the AppDomain and decided to remove both RadControls web applications from my VS solution, save and close it.  Then I re-opened it and added a new one, and so far it has been working without any issues.

    Again, this did work for me and is still working, so hopefully it will help others.


    King Wilder
  3. taylor
    taylor avatar
    3 posts
    Member since:
    Nov 2008

    Posted 03 Apr 2012 Link to this post

    I had a similar issue. Mine was slightly different because the version and public key token were the same for type A and B in my error message, but they were coming from 2 different directories in the project assemblies directory. This started happening once I upgraded to Q1 2012. I just deleted the folder for type B and restarted VS and it seems to be working for the time being.
  4. David
    David avatar
    2 posts
    Member since:
    Aug 2014

    Posted 02 Jul 2015 Link to this post

    (Use Google translator if you don't read spanish) 

    Ya lo tengo!.

    Es simple si lo miras desde el punto de vista de Visual Studio: Cada vez que se extiende VS con controles, en realidad se agregan DLLs conteniendo esa funcionalidad. Algunos accesibles en tiempo de diseño y otros solo en tiempo de ejecución.

    Al actualizar la suite de Telerik, las REFERENCIAS en las SOLUCIONES NO se actualizan   :-(

    SOLUCION: Eliminar las referencias y volverlas a crear.

       1.-Click derecho en LA SOLUCION y elegir "Property pages"

       2.-Remover las 2 referencias a "Telerik.Web.UI" y "Telerik.Web.UI.Skins"

       3.-Click en Add => Add  reference y dar click en Browse...    (paso muy importante, no tomar las existentes)

      4.-Navegar hacia donde esté instalado Telerik y la version de .net que se esté utilizando en la solución. En mi caso: C:\Program Files (x86)\Telerik\UI for ASP.NET AJAX Q2 2015\Bin45

       5.-Seleccionar "Telerik.Web.UI.dll" y "Telerik.Web.UI. Skins.dll"

       6.-Click en Add => OK => OK

       7.-Cerrar todas las ventanas del Editor.

       8.-Click derecho en Solución y seleccionar "Build Web Site"

    Abrir Default.aspx (ó la página con controles) en modo diseño para verificar.


    En algunas soluciones el folder de referencias se encuentra directamente en la solución. Seguir los misma idea pero remover las referencias erroneas y dar click derecho en la palabra "Reference" => "Add Reference"


  5. Nicole
    Nicole avatar
    1 posts
    Member since:
    Oct 2015

    Posted 31 Aug 2016 in reply to David Link to this post

    David, Thank you so much.  This was the most helpful tutorial for this error that I've come across.  Your solution worked for me!
  6. Hamada
    Hamada avatar
    4 posts
    Member since:
    Dec 2014

    Posted 29 Nov 2016 Link to this post

    I Did 

    Build -----> Clean "Your project name"

    Build ------> Build "Your Project Name" 


    got it back to normal  :) 


  7. Tricewebdevelopment
    Tricewebdevelopment avatar
    1 posts
    Member since:
    Oct 2017

    Posted 23 Oct 2017 Link to this post

Back to Top