This is a migrated thread and some comments may be shown as answers.

EnableValidation = false does not work

4 Answers 84 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Markus
Top achievements
Rank 2
Markus asked on 23 May 2008, 02:53 PM
Hello!

Setting EnableValidation to false has NO effect on page.

The grid ALLWAYS validates.

I have to hack around with validation groups.

is this a bug?.

thx in advance
Markus

4 Answers, 1 is accepted

Sort by
0
Eric
Top achievements
Rank 2
answered on 23 May 2008, 05:36 PM
Did you find your answer? I am searching for the same thing.  In my case I have a grid and when I try to apply the grid filter it cause a validation on some other text box furthur down the page.  I tried the ValidationSettings-EnableValidation="false" but it has no effect.  I aslo tried to add <ValidationSettings  EnableValidation="false"  />  and this as well did not change anything.  Let's hope that someone will jump in to let's us know how to do so.
0
Sebastian
Telerik team
answered on 26 May 2008, 06:22 AM
Hi guys,

Can you specify the steps to reproduce the erroneous behavior on this online demo of the product? I tried to do that but unfortunately to no avail. This can help us identify the source of the issue and provide a solution for it. Thank you for your cooperation.

Best regards,
Stephen
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Mohammed Ahmed
Top achievements
Rank 1
answered on 26 May 2010, 10:29 PM

If you have validation controls and RadGrid in the same page, when you are trying to add a new record using the RadGrid Insert command the other control in the same form will fire validation. To solve this issue use this setting in your RadGrid

 

<ValidationSettings EnableValidation="false" CommandsToValidate="NO" ValidationGroup="no" />

 

Basically I am tricking the RadGrid control by passing bogus string to CommandToValidate and ValidationGroup in addition to EnabelValidation should be set to false.

 

I believe this a bug in telerik control but they claim fixed the issue.


I use version: 2009.3.1407.35
 

Thanks

 

0
Chamin
Top achievements
Rank 1
answered on 14 Jun 2012, 10:02 AM
This issue still exist.
I tried several ways to stop the validation process when I click the "Select" command in RadGrid as follows,

ValidationSettings-EnableValidation="false" >
                                    <ValidationSettings EnableValidation = "false" CommandsToValidate ="NO" ValidationGroup = "no"/>

Could you please help me to sort it out....

Tags
Grid
Asked by
Markus
Top achievements
Rank 2
Answers by
Eric
Top achievements
Rank 2
Sebastian
Telerik team
Mohammed Ahmed
Top achievements
Rank 1
Chamin
Top achievements
Rank 1
Share this question
or