This is a migrated thread and some comments may be shown as answers.

EnableEmbeddedSkins="false" issue.

10 Answers 817 Views
Window
This is a migrated thread and some comments may be shown as answers.
SamVanity
Top achievements
Rank 2
SamVanity asked on 21 Nov 2007, 05:46 AM
Hi,

I am setting EnableEmbeddedSkins="false" in my skin file so I am sure it is applied to all instances of RadWindow. however, I am still seeing the webresource.axd sending the embeded
/* RadWindow 2 Common Css */
CSS file, although it does not send the skin specific CSS file.

I did the same for all other rad controls and it works for all of them, except RadWindow.

10 Answers, 1 is accepted

Sort by
0
Georgi Tunev
Telerik team
answered on 21 Nov 2007, 01:50 PM
Hi Sam,

Indeed, this behavior is by design - some of our controls, including RadWindow have a common CSS which will be loaded every time if a RadWindow is rendered on a page. This allows easier customization of the existing skins or adding new ones.

Is this behavior a problem for you? We will be glad to hear your thoughts on that matter.



Greetings,
Georgi Tunev
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
SamVanity
Top achievements
Rank 2
answered on 21 Nov 2007, 03:52 PM
it is not a problem for me at this very moment since I haven't had the need to customize the Common CSS file.

However, when I set EnableEmbeddedSkins to false, I expect to control the skinning part completely, and since you are providing the "RadWindow 2 Common CSS" as a CSS file as well, webresource.axd just overwrites whatever I may have changed in the Window.css file (I am using ASP.NET Skin, and webresource.axd is declared after the theme and skin CSS files).

So, not a problem at this moment, but webresource.axd being loaded later will overwrite whatever changes I make to the common CSS file.
0
Georgi Tunev
Telerik team
answered on 21 Nov 2007, 04:18 PM
Hello Sam,

Thank you for your feedback. I logged this thread in our database and we will take it into consideration in one of our internal meetings.




All the best,
Georgi Tunev
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Grendizer
Top achievements
Rank 1
answered on 24 Oct 2008, 09:26 AM
Hello guys,

It seems this issue is still present in the last build [1001].

Is there any news from your side, we currently need to put our own css desgin on the window.

Many thanks in advance for your answer.

0
Tervel
Telerik team
answered on 24 Oct 2008, 03:26 PM
Hi Grendizer,

To turn of the "second" stylesheet, we have introduced an additional property that you need to set:

EnableEmbeddedBaseStylesheet=false

Greetings,
Tervel
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
nenita
Top achievements
Rank 1
answered on 24 Dec 2008, 03:55 PM
Hi, i want to ask something , how can i put enableembeddedskins for all page 
for example i put inside my web.config this tag
 <add key="Telerik.Skin" value="Telerik2"/>
and change all style but, i have to put in all controls enableembeddedskins to false,
 because if not i have an error
"Please, make sure that you spelled the skin name correctly, or if you want to use a custom skin, set EnableEmbeddedSkins=false."
but I want that is enabled for all page like on the example.
it's that possible?
or my only chance its put them on all controls?
I hope you understand me , sorry for my english, it's not my mother language.
I'm learning.
Regard nenita.







0
Georgi Tunev
Telerik team
answered on 29 Dec 2008, 09:14 AM
Hi nenita,

You need to set the EnableEmbeddedSkins property in the same way in the web.config as well. More information on the subject is available here: (check the Disabling Embedded Skins section)
http://www.telerik.com/help/aspnet-ajax/disabling_embedded_resources.html

Sincerely yours,
Georgi Tunev
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
nenita
Top achievements
Rank 1
answered on 29 Dec 2008, 10:01 PM
Me again...
Thanks for your answer, but i don't fix my error, :(  i have the following code on my webconfig:
<add key="Telerik2.EnableEmbeddedSkins" value="false"/>
    <add key="Telerik2.EnableEmbeddedBaseStylesheet" value="false"/>
    <add key="Telerik2.EnableEmbeddedScripts" value="false"/>
    <add key="Telerik2.Skin" value="Telerik2"/>
and later on my masterpage I put the following:
<link href="Skins/Telerik2/Grid.Telerik2.css" rel="stylesheet" type="text/css" />
.... this is the location of my customize skin and css file. 
the results is the page only show the default skin and if i put:
Or i put something like that:
<add key="Telerik2.Skin" value="Telerik2"/>
    <add key="Telerik.Skin" value="Telerik"/>
    <add key="Telerik.EnableEmbeddedSkins" value="false"/>
    <add key="Telerik.EnableEmbeddedBaseStylesheet" value="false"/>
    <add key="Telerik.EnableEmbeddedScripts" value="false"/>
 have a javascript error: telerik is undefined , i put that because i thought 'telerik' is by default and i have to disabled. 
but i don't know now what's going on.

Please I apreciate again some helps.
thanks in advance
nenita.


0
Georgi Tunev
Telerik team
answered on 30 Dec 2008, 01:20 PM
Hello Nenita,

I am not quite sure what does Telerik2 stands for, but I suggest to try with the following settings:
<add key="Telerik.Skin" value="Telerik"/>
<add key="Telerik.EnableEmbeddedSkins" value="false"/>
<add key="Telerik.EnableEmbeddedBaseStylesheet" value="false"/>


Note: do not set EnablembeddedScripts to false unless you are manually adding the scripts - that is where "telerik is undefined" comes from.

If you still experience problems, please try to isolate them in a small sample project and send that project to us in a support ticket - we will check it and do our best to help.



Kind regards,
Georgi Tunev
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
nenita
Top achievements
Rank 1
answered on 02 Jan 2009, 07:14 PM
Thanks for the advice, it's works.
<appSettings>
    <add key="Telerik.Skin" value="MyNewSkin"/>
    <add key="Telerik.EnableEmbeddedSkins" value="false"/>
    <add key="Telerik.EnableEmbeddedBaseStylesheet" value="false"/>
  </appSettings>
I put these on my web.config and I registered on my MasterPage the following:
<head runat="server">
<link href="Skins/MyNewSkin/ComboBox.MyNewSkin.css" rel="stylesheet" type="text/css" />
..</head>

Thanks again. 

Tags
Window
Asked by
SamVanity
Top achievements
Rank 2
Answers by
Georgi Tunev
Telerik team
SamVanity
Top achievements
Rank 2
Grendizer
Top achievements
Rank 1
Tervel
Telerik team
nenita
Top achievements
Rank 1
Share this question
or