This is a migrated thread and some comments may be shown as answers.

Empty Data Source Type List in VS2012

5 Answers 160 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Gary
Top achievements
Rank 1
Gary asked on 08 Jan 2013, 03:54 PM
Initially it worked and then for some unknown reason, the Data Source Type list failed to appear at all.

Would like to know if there's a workaround. Have tried a reinstall of Reporting and that does not change anything.

How can I add a datasource in code that will appear in the designer. Have tried hacking the designer code but that gets overwritten.
An example would be good otherwise it's going to prove difficult to use Reporting at all.

Screen shot attached.

5 Answers, 1 is accepted

Sort by
0
Steve
Telerik team
answered on 10 Jan 2013, 12:57 PM
Hello Gary,

There was such a problem in earlier version of the product, that is resolved in the Q3 2012 release (v. 6.2.12.1017) of the product. If you're using this version or newer, please check whether the VS Toolbox contains a Tab for Telerik Reporting and whether this Tab is populated with report items. If such is missing or is empty, please choose Reset Toolbox from the context menu of Visual Studio Toolbox and try again. You need to have only a single VS instance opened at this time and you might have to restart Visual Studio after the reset.

If after resetting the toolbox the report items are still missing we will appreciate if you go through the Telerik Reporting Toolbox items are missing article and send us the log.

All the best,
Steve
the Telerik team

HAPPY WITH REPORTING? Do you feel that it is fantastic? Or easy to use? Or better than Crystal Reports? Tell the world, and help fellow developers! Write a short review about Telerik Reporting and Telerik Report Designer in Visual Studio Gallery today!

0
Negin
Top achievements
Rank 1
answered on 23 Jan 2013, 06:48 AM
Hi,
Apparently i could solve the problem! :)
I use VS 2012 and have Telerik (v. 6.2.12.1025) installed on my computer. i experienced the exact problem and i did what Steve said but it didn't worked! none of the telerik reporting items where in the toolbox and the data source selecting wizard showed no data sources to select! I reset the toolbox and there was no change in toolbox and data source wizard!

****************************************
Do these steps, it worked for me, i hope the same for you ;) (This has been tested in VS 2012 Only!)

1- Go to:  "Tools" ->  "Choose Toolbox Items"
          [Note: you can`t see "Choose Toolbox Items" in "Tools" menu if your VS is set to certain development settings. but you should see it if your VS is set to "General Development Settings", however if you want to reset your VS to "General Development Settings" follow these steps
         1- Go to: "Tools" -> "Import and Export Settings".
         2- Choose "Reset all settings" and click "Next".
         3- Choose the way you want VS to save your current settings. Consider that after VS resets you will loose all of your settings
              so it is recommended that you create a backup of your current settings to export in VS later. Click "Next".
         4- Choose "General Development Settings" and click "Finish".
         5- Restart VS.

2- Choose " .Net Framework Components" tab.
3- Check all items related to Telerik assembly.
[To do this you can sort the items by "Assembly Name"]. Click "OK".
4- Restart VS.


Now you should see all Telerik reporting Items and all available data sources when you open data source selecting wizard for your report! :)

Good luck!
Negin
0
Paul D.
Top achievements
Rank 1
answered on 26 Jun 2013, 07:06 PM
Negin:
Thank you !
I have been through multiple forums, countless iterations of devenv /Resetyadayadayayda, uninstalls, reinstalls, etc...
and it all turned out to be this totally simple thing !

My setup was VS 2010, win7 64 bit, etc...
-Paul D.
0
Dave
Top achievements
Rank 1
answered on 23 Oct 2013, 12:36 AM
Thank You Negin! I experienced the same issue when upgrading to Reporting Q3 2013 for VS 2012, but this fix worked!!

Dave
0
Rute
Top achievements
Rank 1
answered on 22 Feb 2017, 04:06 PM

Dear all, for no data source in VS2012 of telerik 

Thank you for Negin , your method is working

1- Go to:  "Tools" ->  "Choose Toolbox Items" 
          [Note: you can`t see "Choose Toolbox Items" in "Tools" menu if your VS is set to certain development settings. but you should see it if your VS is set to "General Development Settings", however if you want to reset your VS to "General Development Settings" follow these steps
         1- Go to: "Tools" -> "Import and Export Settings".
         2- Choose "Reset all settings" and click "Next".
         3- Choose the way you want VS to save your current settings. Consider that after VS resets you will loose all of your settings
              so it is recommended that you create a backup of your current settings to export in VS later. Click "Next".
         4- Choose "General Development Settings" and click "Finish".
         5- Restart VS.

2- Choose " .Net Framework Components" tab.
3- Check all items related to Telerik assembly. [To do this you can sort the items by "Assembly Name"].

****For the filter blank area , you can write down " Telerik " and all related Telerik would be filtered and show on display

and then tick all of them and press "OK"

4- Restart VS. by restart your computer

I hope it will works for you guys

 

Good Luck

 

Rute


Tags
General Discussions
Asked by
Gary
Top achievements
Rank 1
Answers by
Steve
Telerik team
Negin
Top achievements
Rank 1
Paul D.
Top achievements
Rank 1
Dave
Top achievements
Rank 1
Rute
Top achievements
Rank 1
Share this question
or