Editor displaying oddly with new padding in IE6 in radGrid

2 posts, 0 answers
  1. Adam King
    Adam King avatar
    29 posts
    Member since:
    May 2010

    Posted 16 Mar 2011 Link to this post

    Our editor in a radGrid displays different/incorrectly in ie6

    One of the columns has a RadEditor which works fine in ie8 but on ie6 it somehow shrinks the textbox vertically and adds think blue borders on all sides. The text is now not visible unless the height is almost doubled. It just displays white for each row.
    The exact same column markup looks fine in a formView, problem is just the radGrid.

    We just switched from a gridview inside a radDock & radDockZone to a RadGrid (again inside a radDock & radDockZone )

    The gridview worked fine but the radGrid is having this problem.

    Any ideas? I have a feeling it is a css issue but can not see where.

    My column code is:

    <telerik:GridTemplateColumn HeaderStyle-HorizontalAlign="Left" HeaderText="Subject"
                                        AllowFiltering="False" DataType="System.String" UniqueName="Subject">
         <telerik:RadEditor ID="subject" Width="580" AutoResizeHeight="false" runat="server"
                                                                            Enabled="true" content='<%# Bind("subject") %>' Height="46" EditModes="Preview" OnClientLoad="OnClientLoadSubject"
                                                                            ToolsFile="NoTools.xml" EnableEmbeddedSkins="false" >
                                                                                <telerik:EditorCssFile Value="~/App_Themes/Seniors/EditorContentArea.css" />

    and the EditorContentArea.css referenced in the markup above has 4 properties set:

        font-family: Verdana,Arial,Helvetica,Sans-Serif;
        font-size: 13px;

    The file attached is a jpeg of the current editor with the borders in the grid
  2. Adam King
    Adam King avatar
    29 posts
    Member since:
    May 2010

    Posted 17 Mar 2011 Link to this post

    This was solved by adding the following code to the page (containing the radGrid and editor)

    <style type="text/css">
        *html .RadGrid .rgRow td,
        *html .RadGrid .rgAltRow td
            padding: 0!important;
Back to Top