This is a migrated thread and some comments may be shown as answers.

Edge Browser issue with filtered DropDownTree

7 Answers 53 Views
DropDownTree
This is a migrated thread and some comments may be shown as answers.
Chris
Top achievements
Rank 1
Chris asked on 25 Sep 2015, 02:30 AM

Hi,

I have been using Edge as my primary browser since Windows 10 launched and testing my web application with it.

There is a particularly annoying issue with filtered dropdownlists where when you click in the text box to filter Edge brings up it's own autocomplete list of things that you have previously typed into textboxes. The problem is that this sits on top of the tree control and you cannot see it let alone use it.

Pushing escape to get rid of the autocomplete closes the dropdown tree also.

Take a look at the attached screenshot that I took when attempting to access your demo site

http://demos.telerik.com/aspnet-ajax/dropdowntree/examples/overview/defaultcs.aspx

Are you aware of this issue and do you have a fix in the works?

Cheers,

Matt

 

7 Answers, 1 is accepted

Sort by
0
Ivan Danchev
Telerik team
answered on 29 Sep 2015, 05:07 PM
Hello Matt,

I am afraid I was not able to reproduce the described behavior in the demo you linked. At my end the demo looks and works as in the other browsers, including the ESC key closing the DropDownTree. Could you please specify step-by-step the actions a user has to take in order for the issue to be replicated? If it is more convenient for you, you can record a short video (with Jing for instance) that demonstrates the issue.

Regards,
Ivan Danchev
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Chris
Top achievements
Rank 1
answered on 29 Sep 2015, 10:59 PM

Hi Ivan,

I have narrowed it down to the "save form entries" option hidden in the advanced settings of Edge.

If this is disabled it works without issue. Further to this if I clear the "form data" it also goes back to working.

Note that originally over time I built up a collection of saved values and have found not all forms cause the issue.

If you go to the following URL

https://avinet.saas.appdynamics.com/controller/

 

and enter test, test, test and click login, which will of course fail.

Now test should appear on

http://demos.telerik.com/aspnet-ajax/dropdowntree/examples/overview/defaultcs.aspx

as explained when you open the dropdown list and click in the filter box.

 
 
0
Ivan Danchev
Telerik team
answered on 02 Oct 2015, 02:29 PM
Hello Matt,

Thank you for the additional information provided.

We were able to reproduce the behavior following the steps you described. It seems this is an Edge browser-behavior related to the saving option you have found, as it was reproduced not only with our DropDownTree control but with a simple <input> element as well. Since the DropDownTree's input area renders as an input element it is affected as well.

Regards,
Ivan Danchev
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Chris
Top achievements
Rank 1
answered on 06 Oct 2015, 03:08 AM

Hi Ivan,

good to hear that you have been able to replicate the issue.

I understand that this is a browser issue and not a dropdowntree issue, however was wondering if you had come up with a workaround or fix for the issue. I am not sure if there is anything that we can do to the input field so that Edge excludes it from this functionality.

Unfortunately telling users to either not use Edge or change that setting is not ideal and we have just started using the dropdowntree control quite heavily in our web application.

Thanks

Matt

0
Ivan Danchev
Telerik team
answered on 07 Oct 2015, 02:35 PM
Hello Matt,

As a workaround until the browser behavior with the setting in question is fixed/changed by MS, you can set the "autocomplete" attribute of the form tag of your page as shown below:
<form id="form1" runat="server" autocomplete="off">

Regards,
Ivan Danchev
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Chris
Top achievements
Rank 1
answered on 07 Oct 2015, 11:16 PM

Thanks Ivan,

I can confirm that this workaround does work and resolves my issue.

Matt

0
Ivan Danchev
Telerik team
answered on 08 Oct 2015, 02:54 PM
Hello Matt,

I am glad setting the attribute solves the issue at least temporarily, until an official solution becomes available.
 
Regards,
Ivan Danchev
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
DropDownTree
Asked by
Chris
Top achievements
Rank 1
Answers by
Ivan Danchev
Telerik team
Chris
Top achievements
Rank 1
Share this question
or