This is a migrated thread and some comments may be shown as answers.

Dropdown style controls in RadWindow

7 Answers 34 Views
Window
This is a migrated thread and some comments may be shown as answers.
Robert
Top achievements
Rank 1
Robert asked on 23 Mar 2012, 08:04 AM
Any type of control which has a drop down, like ComboBox, Listbox become hidden when clicked within a RadWindow.
It seems to happen on Windows XP machines.

If you set the radwindow to IsTopMost then the combobox is visible, but I do not want to use this method.
I have tried a lot of things, but with no success. (including setting zindex)

Is this a bug with radwindow, and is there a workaround? I am using mvvm, so would rather not have to do any code behind.

7 Answers, 1 is accepted

Sort by
0
Georgi
Telerik team
answered on 27 Mar 2012, 08:51 AM
Hello Robert,

I have tried to reproduce it in both Windows 7 and Windows XP, but with no luck. I have attached a video and a simple project. It would be great if you can tell us if we are doing something different?

Kind regards,
Georgi
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Robert
Top achievements
Rank 1
answered on 27 Mar 2012, 09:56 AM
I tried your sample application, but with no luck. I have attached a screenshot on how it looks like.
This tends to happen randomly, and only on Windows XP from what I have seen.
Normal window is fine, it just happens with RadWindow, and when it does happen, it affects all controls with the drop down.
0
Georgi
Telerik team
answered on 28 Mar 2012, 01:24 PM
Hello Robert,

So If you are not able to reproduce the behavior in my application, can you please send me a project where it is reproducible ( or at least happens sometimes)? I saw your picture and it got me some ideas about what could be wrong. I have seen similar problem when you try to open a drop down and inside you have a lot of data to be loaded. If this is the case, using a Dispatcher should work.
Hope this is helpful.


Greetings,
Georgi
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Robert
Top achievements
Rank 1
answered on 28 Mar 2012, 06:11 PM
The bad news is...
I was using the sample application you sent me in that screenshot:)
0
Georgi
Telerik team
answered on 30 Mar 2012, 10:21 AM
Hello Robert,

It is indeed very strange. So if it is happening on your machine and not on mine it might be environmental, so we need to find what is different. I am using 2012.1.215 version of the controls. We used to have similar problem with old versions. Also I am using Windows XP Visual Studio 2010, Framework  4.0. Any differences?

Kind regards,
Georgi
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
0
Robert
Top achievements
Rank 1
answered on 30 Mar 2012, 01:05 PM
No difference in environment. Using pretty much the same. Also I had tried the controls since June Q2  2011 till the latest March Q1 SP1, and they all had the same issue.

I think I know how it happens now.
When I am using a secondary monitor connected to my laptop, it seems to happen then. Even if I unplug the monitor, the same issue happens, until I reboot my laptop.

Hopefully you can replicate the issue.
0
Georgi
Telerik team
answered on 04 Apr 2012, 09:14 AM
Hello Robert,

We have logged the issue in our Public Issue Tracking System. Here you can vote and track the progress of fixing it.


All the best,
Georgi
the Telerik team
Sharpen your .NET Ninja skills! Attend Q1 webinar week and get a chance to win a license! Book your seat now >>
Tags
Window
Asked by
Robert
Top achievements
Rank 1
Answers by
Georgi
Telerik team
Robert
Top achievements
Rank 1
Share this question
or