This is a migrated thread and some comments may be shown as answers.
Device Filters
2 Answers 35 Views
This is a migrated thread and some comments may be shown as answers.
Alice
Top achievements
Rank 1
Alice asked on 02 Aug 2008, 03:22 AM
I'm sure I'm missing something really obvious.  I started a new Ajax enabled site with a master page.  On the master page I created a rad menu in a div with a content place holder under that. 

I want to use the menu item to allow the users to navigate from one section of our company site to another (basically webforms within the project.)

Using the build menu feature, I've created one root item and set the navigate url page to Default.aspx.

On the web form connected the master page the menu control creates an error that says "the string telerik:telerik:radmenuitem1 contains too many device filters. There can be only one."

I'm not sure what I'm doing wrong but this happens with the treeview and context menu as well so I'm thinking there must be some kind of reference file I need to put in the project or I'm using the NavigateUrl incorrectly.

Appreciate the help.

2 Answers, 1 is accepted

Sort by
0
Alice
Top achievements
Rank 1
answered on 02 Aug 2008, 05:35 PM
You know what's strange is that even though in design view the control has a creating error, when I run the page the menu seems to be working okay so far.
0
Alice
Top achievements
Rank 1
answered on 03 Aug 2008, 05:52 PM
Silly me.  This is a one sided conversation so far I know, but I think I fixed the problem, once I downloaded the latest release.  I noticed I didn't have it when I saw that the tab strip was release for AJAX.
Tags
Menu
Asked by
Alice
Top achievements
Rank 1
Answers by
Alice
Top achievements
Rank 1
Share this question
or