This is a migrated thread and some comments may be shown as answers.

DB Scheduler provider sample wont work

2 Answers 103 Views
Scheduler
This is a migrated thread and some comments may be shown as answers.
Gustavo Roman
Top achievements
Rank 1
Gustavo Roman asked on 10 Nov 2008, 05:12 AM
Check your link: http://demos.telerik.com/ASPNET/Prometheus/Scheduler/Examples/DbSchedulerProvider/DefaultCS.aspx
To be able to save data in my own SQL DB you suggest the following:

In order to turn on the write support, you need to download and run the samples locally. Set the RadScheduler's ReadOnly property to "false", then change persistChanges to true in web.config:

    <telerik.web.ui>

        <radScheduler defaultAppointmentProvider="Integrated">

            <appointmentProviders>

                <add name="ReadOnlySchedulerData" type="Telerik.Web.Examples.Scheduler.MyDbSchedulerProvider"

                    connectionStringName="TelerikConnectionString"

                    persistChanges="true" />

            </appointmentProviders>

        </radScheduler>

    </telerik.web.ui>



I followed every single instruction and also modified the ConnectionStrings to point at my own SQL Express 2008.
Ran the application without problems but the data is not being saved in my SQL DB 'SchedulerData'.

Thanks in advance for your help.


2 Answers, 1 is accepted

Sort by
0
Gustavo Roman
Top achievements
Rank 1
answered on 10 Nov 2008, 04:09 PM
I got a message from my ASP.net express edition 2008 environment indicating that Telerik does not support datasources from SQL 2008 yet. So I moved the SQL DB SchedulerData to a SQL 2005 server but still, when I run the web page ResourceGrouping/DefaultVB.aspx the following message gets displayed under the control: 

Note: The changes in the data will be persisted per Session only. The data will be reset next time you visit the page.

Here are your instructions, please let me know if you missed something:

In order to turn on the write support, you need to download and run the samples locally. Set the RadScheduler's ReadOnly property to "false", then change persistChanges to true in web.config:

    <telerik.web.ui>

        <radScheduler defaultAppointmentProvider="Integrated">

            <appointmentProviders>

                <add name="ReadOnlySchedulerData" type="Telerik.Web.Examples.Scheduler.MyDbSchedulerProvider"

                    connectionStringName="TelerikConnectionString"

                    persistChanges="true" />

            </appointmentProviders>

        </radScheduler>

    </telerik.web.ui>

0
T. Tsonev
Telerik team
answered on 11 Nov 2008, 01:43 PM
Hello Gustavo,

There are not issues with using SQL Server 2008 Express, at least, we are not aware of any. There is probably something else that we are missing.

The change that you have made in the web.config looks fine. Also, at the very minimum, your RadScheduler tag should look like this:

<telerik:RadScheduler runat="server" ID="RadScheduler1" 
     ProviderName="ReadOnlySchedulerData"
</telerik:RadScheduler> 
 

The default value of the ReadOnly property is "false", so you can simply omit it.

Another thing to check for is that the database you are using has the correct schema. Try binding against the supplied database (App_Data/Telerik) just to make sure that the problem is not in the database itself.

Regards,
Tsvetomir Tsonev
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
Tags
Scheduler
Asked by
Gustavo Roman
Top achievements
Rank 1
Answers by
Gustavo Roman
Top achievements
Rank 1
T. Tsonev
Telerik team
Share this question
or