This is a migrated thread and some comments may be shown as answers.

Custom Html tags replaces

6 Answers 140 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Beelze
Top achievements
Rank 1
Beelze asked on 19 Apr 2010, 05:50 PM
Hi.

I have a problem entering custom html tags into the editor.
for example (paste only this html into the editor):
<h1>Test template</h1> 
Content starts here: <br /> 
<placeholder name="Content" /> 
<br /> 
Content ends here! 
will be replaced to (after a roundtrip to the server for saving):
<h1>Test template</h1> 
Content starts here: <br /> 
<name="Content">Content ends here!</p> 

So my custom <placeholder> tag is getting merged with the last <br /> and replaced by <p>.
How do I get around this? I have set StripFormattingOptions="None" and AllowScripts="true" on the editor.

If I encapsulate my custom tag inside a <div> tag, everything works fine:
<h1>Test template</h1> 
Content starts here: <br /> 
<div><placeholder name="Content" /></div>  
<br /> 
Content ends here! 
(will be preserved after roundtrip to the server).

Thanks,
JJ

6 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 20 Apr 2010, 01:52 PM
Hi Beelze,

The reported behavior is due to the Rich Text Editing engine of Firefox that the editor's content area IFRAME uses in this browser. You can reproduce the same behavior in the attached HTML file having an editable IFRAME in it as well as in our competitors' editors.

This behavior does not occurs in Internet Explorer.

Since this is a browser behavior which is not controlled by RadEditor, we cannot provide a solution, because we could not handle this tag with code.

What you can do is to close custom placeholder tag directly after the opening one, e.g.

<h1>Test template</h1>
Content starts here: <br />
<placeholder name="Content"></placeholder>
<br />
Content ends here!

Greetings,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Beelze
Top achievements
Rank 1
answered on 20 Apr 2010, 02:33 PM
Okay - Thanks anyway.

You might want to know that I am indeed using Internet Explorer 8 and it was in this browser I discovered the issue. I have not tested this issue in FireFox, but as say you have, this issue occurres both in IE and FireFox.
0
Rumen
Telerik team
answered on 20 Apr 2010, 02:41 PM
Hi Beelze,

This is odd, because I was unable to reproduce the problem in IE8. For your convenience I have attached a video demonstrating my test. Nevertheless, if you experience this problem in IE, then this will be again browser behavior.


Regards,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Beelze
Top achievements
Rank 1
answered on 20 Apr 2010, 02:52 PM
Is it just me and my eyes??? if you look closely after in your posted video, you can see a space between the "p" and "l" in <p laceholder> after you show the html in the video for the second time - where does this come from? You can also see there is no closing tag for the placeholder + the placeholder is now all capitalized letters - Please check your own video to confirm the error is there in IE as well.

I have taken a screenshot from your own video and attached it so you can see the generated code is not working...
0
Rumen
Telerik team
answered on 20 Apr 2010, 03:28 PM
Hello Beelze,

Thank you for reporting this. I haven't noticed that the p is divided from the rest of the tag name.

 I was able to solve this problem by setting a namespace for the custom tag:

<h1>Test template</h1>
Content starts here: <br />
<my:placeholder name="Content"></my:placeholder>
<br />
Content ends here!

In IE it is recommended to set namespaces for the custom tags: Using Custom Tags in Internet Explorer.

The tag capatialization is due to the Rich Text Editing engine of IE - the ConvertToXhtml filter fixes this problem and makes all tags upper case.

Greetings,
Rumen
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Beelze
Top achievements
Rank 1
answered on 20 Apr 2010, 03:41 PM
Thank you so much for your help :)
Using namespaces for custom tags makes sence...

Have a nice day!
Tags
Editor
Asked by
Beelze
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Beelze
Top achievements
Rank 1
Share this question
or