CTRL+SHIFT+V in Chrome no longer works.

3 posts, 0 answers
  1. Sam Tran
    Sam Tran avatar
    85 posts
    Member since:
    Nov 2006

    Posted 19 Jun 2013 Link to this post

    Hi,

    Using CTRL+SHIFT+V in Chrome is supposed to paste without formatting.
    Prior to the latest release, this worked.

    With this latest release, if I copy, for example, a grid row that has an alternating color and then CTRL+SHIFT+V into RadEditor, it carries the color over into the RadEditor.

    Was this an intentional change?
  2. Ivaylo
    Admin
    Ivaylo avatar
    37 posts

    Posted 20 Jun 2013 Link to this post

    Hello Sam,

    Thank you for sharing your observation.

    The reported issue is a known bug that we have already logged internally into our system and we will be working on fixing it. The reason causing it is the Paste As Plain Text option (the function behind the Ctrl+Shift+V shortcut) from the right-click context menu which does not function properly in Chrome. I am afraid that, currently, I cannot give a firm estimate when it might be resolved.

    In the mean time, the only possible workaround that I can suggest is to use the Paste Options tool and the Paste Plain Text dialog as a substitute to the context-menu command. To customize them for better user experience, you can refer to the following article in the Editor's documentation: Keyboard Support, in which several guidelines on how to define shortcuts for the existing tools are given.

    Thank you for your patience and, please, excuse us for the temporary inconvenience. Should you have any other questions, do not hesitate to contact us.

    Regards,
    Ivaylo
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
  3. Ivaylo
    Admin
    Ivaylo avatar
    37 posts

    Posted 20 Jun 2013 Link to this post

    Hello Sam,

    Just as a quick follow up - we found another solution which will better resemble the behavior, exhibited in previous versions of the control and which you might find more convenient.

    The solution lies in overriding the containsHtmlAtClipboard function with the following JavaScript code, that needs to be placed after the Editor's declaration in the page:
    <script type="text/javascript">
      Telerik.Web.UI.Editor.Utils.containsHtmlAtClipboard = function (event)
      {
        return false;
      }
    </script>

    I hope that you will find the provided solution satisfactory. Feel free to contact us if you have any other questions.

    Regards,
    Ivaylo
    Telerik
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
Back to Top