This is a migrated thread and some comments may be shown as answers.

CrossTable does appears anymore since upgraded to Q2 2009

4 Answers 25 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Frédéric
Top achievements
Rank 1
Frédéric asked on 10 Dec 2009, 02:21 PM
Hello,

I have a TextBox and a CrossTable in a detail section, both set to visible= false.

In the detail section ItemDataBinding event, I set one of those two controls to visible= true depending of a value in the data row.

This used to works fine in Q1 2009 but since I have upgraded the report to Q2 2009, when I set the CrossTable visible to true, the CrossTable does not appears anymore.

I have tried with Q3 2009 and it still does not work like it used to be.

Thanks

Frédéric

4 Answers, 1 is accepted

Sort by
0
Frédéric
Top achievements
Rank 1
answered on 10 Dec 2009, 06:44 PM
I meant "does NOT appears anymore" in the title
0
Steve
Telerik team
answered on 14 Dec 2009, 02:01 PM
Hi Frédéric,

We have not introduced any changes in the Table/CrossTab item that relate to the item's visibility and since we have not been able to replicate this locally, would appreciate if you prepare and zip a sample report that shows the problem you experience.

On a side note, your scenario (hiding item depending of a value of data row) is perfect "candidate" for using our Conditional Formatting. Simply create a rule that would check the Value and when the rule is met, uncheck the Visible checkbox in the Layout Pane.

Sincerely yours,
Steve
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Frédéric
Top achievements
Rank 1
answered on 15 Dec 2009, 01:39 PM
Hi,

I have submitted a support ticket (ID:266641) with a repro of the behavior.

In the mean time, I will try the conditional formating.

Thanks for the suggestion.

Frederic
0
Frédéric
Top achievements
Rank 1
answered on 15 Dec 2009, 03:46 PM
Hi,

This has been confirmed to be a bug but conditional formating did the trick for my scenario.

Thanks
Tags
General Discussions
Asked by
Frédéric
Top achievements
Rank 1
Answers by
Frédéric
Top achievements
Rank 1
Steve
Telerik team
Share this question
or