Could not resolve type System.Web.UI.ClientIDMode

4 posts, 0 answers
  1. Tim
    Tim avatar
    23 posts
    Member since:
    Nov 2010

    Posted 11 Jan 2012 Link to this post


    I'm working with RadControls Q2 2011 on a project (yes I know I have to update).  It's working fine on one computer but when I open this project on my laptop I've been getting all sorts of errors.  I finally have them all worked out except this one.  The target framework is 3.5.  I've tried adding the AutoID setting to the web.config <pages> section but I kept getting an error that the attribute wasn't allowed (maybe because it's for 4.0?).  Somehow I don't think that's my problem considering this project works fine under my workstation.  I thought it was strange that the version listed in the error for System.Web is 2.0 considering I have no references to 2.0 since I'm using 3.5.  In the properties pages references I see all of my .NET references are to 3.5.  For kicks I tried adding a reference to System.Web 2.0 but received an error that the web site is already referencing the assembly System.Web.  Any ideas?

    Error Creating Control - RadGrid1
    Could not resolve type System.Web.UI.ClientIDMode in assembly System.Web, Version=

    Thanks for the help!!
  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 11 Jan 2012 Link to this post

    Hello Tim,

    Take a look at the following help documentation.
    General Troubleshooting.

  3. Gert Petersen
    Gert Petersen avatar
    19 posts
    Member since:
    May 2009

    Posted 24 Feb 2012 Link to this post

    there is no help to find in there !
    I have the same problem, please give a more specific answer
  4. Andrey
    Andrey avatar
    836 posts

    Posted 29 Feb 2012 Link to this post


    You could try removing all the information from the assembly declaration except the assembly name. This means that you need to remove the Version, Culture, and the PublicKeyToken from the assembly declaration.

    If that does not help you resolve the issue, please share your Web.Config file content.

    Additionally, you could try to close all the opened instances of Visual Studio and then clear the content of these folders:
    • C:\Users\current_user\AppData\Local\Microsoft\VisualStudio\10.0\ProjectAssemblies
    • C:\Windows\Microsoft.NET\Framework\v4.0.30319\Temporary ASP.NET Files

    Give these suggestions a try and check whether the issue is resolved.
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Back to Top