Could not load file or assembly

Thread is closed for posting
8 posts, 0 answers
  1. Aewin
    Aewin  avatar
    19 posts
    Member since:
    Aug 2011

    Posted 09 Sep 2011 Link to this post

    Dear Telerik Team,


    Please do me favor one thing.

    Now,I'm facing the  following error.

    Could not load file or assembly 'Telerik.Web.UI, Version=2011.1.413.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference.

    <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2011.1.413.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false"/>

    Thanks in advance....
  2. Aewin
    Aewin  avatar
    19 posts
    Member since:
    Aug 2011

    Posted 12 Sep 2011 Link to this post

    Hello Telerik Team,

    I need to know answer urgent.You have not yet replied after two days I asked..

    After I changed Telerik licensed dll,that error comes out.

    Which assembly version should I need to change???
  3. Bartholomeo Rocca
    Bartholomeo Rocca avatar
    247 posts
    Member since:
    May 2006

    Posted 13 Sep 2011 Link to this post

    Hello Aewin,

    If you are upgrading from 2011.1.413.40 to latest, you will probably need to update the version in the handler registration as well:

    <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2011.2 712.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false"/>


    Greetings,
    Bart.
  4. Aewin
    Aewin  avatar
    19 posts
    Member since:
    Aug 2011

    Posted 14 Sep 2011 Link to this post

    Hello Bart,

    There's still have error and when I tried the following one,it does work.But I'm not sure it's the correct way or not.
     <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />

    Anyway,Thanks for your reply.
  5. Bartholomeo Rocca
    Bartholomeo Rocca avatar
    247 posts
    Member since:
    May 2006

    Posted 15 Sep 2011 Link to this post

    Hello Aewin,

    Can you post your web.config here? Have you updated both http handlers in the system.web and the system.webServer sections there? Check this help article for more info: http://www.telerik.com/help/aspnet-ajax/introduction-registering-the-httphandlers-on-windows-vista-iis-7-integrated-mode.html.


    Greetings,
    Bart.
  6. Aewin
    Aewin  avatar
    19 posts
    Member since:
    Aug 2011

    Posted 16 Sep 2011 Link to this post

    Sure...

    Please check the following codes.

    Thanks.

    The following code does work.Yellow colour helighted.

    <?xml version="1.0"?>

    <configuration>

           <connectionStrings>

                 

           </connectionStrings>

           <appSettings>

                 

           </appSettings>

           <system.web>

                 

        <anonymousIdentification enabled="true"/>

        <profile enabled="true">

          <properties>

            <add name="SCart" serializeAs="Binary" type="FP.IPS.Business.Entities.Cart" allowAnonymous="true"/>

          </properties>

        </profile>

                  <compilation debug="true" targetFramework="4.0">

                         <assemblies>

                               <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

                               <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

                               <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

                         </assemblies>

                  </compilation>

                  <httpHandlers>

                         <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="HelpDesk.SessionStateDialogHandler" validate="false"/>

                         <add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" validate="false"/>

                         <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>

         <add path="ChartImage.axd" type="Telerik.Web.UI.ChartHttpHandler" verb="*" validate="false" />

                 

                  </httpHandlers>

                  <httpModules>

                         <add name="RadCompression" type="Telerik.Web.UI.RadCompression"/>

                  </httpModules>

                  <pages clientIDMode="AutoID"/>

           </system.web>

           <system.webServer>

                  <validation validateIntegratedModeConfiguration="false"/>

                  <modules>

                         <add name="RadCompression" type="Telerik.Web.UI.RadCompression"/>

                  </modules>

                  <handlers>

                         <add name="Telerik.Web.UI.SpellCheckHandler.axd_*" path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" preCondition="integratedMode,runtimeVersionv2.0"/>

                         <add name="Telerik.Web.UI.DialogHandler.aspx_*" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="HelpDesk.SessionStateDialogHandler" preCondition="integratedMode,runtimeVersionv2.0"/>

                         <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource"/>

        </handlers>

           </system.webServer>

    </configuration>

    --------------------------------------****--------------------------------

    The following codes cause this error.

    Parser Error Message: The given assembly name or codebase was invalid. (Exception from HRESULT: 0x80131047)
    Line 61:       <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2011.2 712.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false"/>

    <?xml version="1.0"?>

    <configuration>

           <connectionStrings>

                 

           </connectionStrings>

           <appSettings>

                 

           </appSettings>

           <system.web>

                  <!--

              Set compilation debug="true" to insert debugging

              symbols into the compiled page. Because this

              affects performance, set this value to true only

              during development.

        -->

        <anonymousIdentification enabled="true"/>

        <profile enabled="true">

          <properties>

            <add name="SCart" serializeAs="Binary" type="FP.IPS.Business.Entities.Cart" allowAnonymous="true"/>

          </properties>

        </profile>

                  <compilation debug="true" targetFramework="4.0">

                         <assemblies>

                               <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

                               <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

                               <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

                         </assemblies>

                  </compilation>

                  <httpHandlers>

                         <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="HelpDesk.SessionStateDialogHandler" validate="false"/>

                         <add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" validate="false"/>

                         <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>

      <add path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2011.2 712.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4" validate="false"/>

                 

                  </httpHandlers>

                  <httpModules>

                         <add name="RadCompression" type="Telerik.Web.UI.RadCompression"/>

                  </httpModules>

                  <pages clientIDMode="AutoID"/>

           </system.web>

           <system.webServer>

                  <validation validateIntegratedModeConfiguration="false"/>

                  <modules>

                         <add name="RadCompression" type="Telerik.Web.UI.RadCompression"/>

                  </modules>

                  <handlers>

                         <add name="Telerik.Web.UI.SpellCheckHandler.axd_*" path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" preCondition="integratedMode,runtimeVersionv2.0"/>

                         <add name="Telerik.Web.UI.DialogHandler.aspx_*" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="HelpDesk.SessionStateDialogHandler" preCondition="integratedMode,runtimeVersionv2.0"/>

                         <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource"/>

    <add name="ChartImage.axd" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2011.2 712.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>

        </handlers>

           </system.webServer>

    </configuration>

    ----------------------------------------********----------------------------------------------

    The following codes cause this error.

    The resource cannot be found.

    <?xml version="1.0"?>

    <configuration>

           <connectionStrings>

                 

           </connectionStrings>

           <appSettings>

                 

           </appSettings>

           <system.web>

                  <!--

              Set compilation debug="true" to insert debugging

              symbols into the compiled page. Because this

              affects performance, set this value to true only

              during development.

        -->

        <anonymousIdentification enabled="true"/>

        <profile enabled="true">

          <properties>

            <add name="SCart" serializeAs="Binary" type="FP.IPS.Business.Entities.Cart" allowAnonymous="true"/>

          </properties>

        </profile>

                  <compilation debug="true" targetFramework="4.0">

                         <assemblies>

                               <add assembly="System.Design, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

                               <add assembly="System.Windows.Forms, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

                               <add assembly="System.Data.Linq, Version=4.0.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

                         </assemblies>

                  </compilation>

                  <httpHandlers>

                         <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="HelpDesk.SessionStateDialogHandler" validate="false"/>

                         <add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" validate="false"/>

                         <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false"/>

                 

                  </httpHandlers>

                  <httpModules>

                         <add name="RadCompression" type="Telerik.Web.UI.RadCompression"/>

                  </httpModules>

                  <pages clientIDMode="AutoID"/>

           </system.web>

           <system.webServer>

                  <validation validateIntegratedModeConfiguration="false"/>

                  <modules>

                         <add name="RadCompression" type="Telerik.Web.UI.RadCompression"/>

                  </modules>

                  <handlers>

                         <add name="Telerik.Web.UI.SpellCheckHandler.axd_*" path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" preCondition="integratedMode,runtimeVersionv2.0"/>

                         <add name="Telerik.Web.UI.DialogHandler.aspx_*" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="HelpDesk.SessionStateDialogHandler" preCondition="integratedMode,runtimeVersionv2.0"/>

                         <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource"/>

    <add name="ChartImage.axd" path="ChartImage.axd" verb="*" type="Telerik.Web.UI.ChartHttpHandler, Telerik.Web.UI, Version=2011.2 712.40, Culture=neutral, PublicKeyToken=121fae78165ba3d4"/>

        </handlers>

           </system.webServer>

    </configuration>

  7. Giuseppe
    Admin
    Giuseppe avatar
    2363 posts

    Posted 21 Sep 2011 Link to this post

    Hello Aewin ,

    We reviewed the attached web.config files and we were able to correctly load the chart with the first one as soon as we added the necessary http handler registration in the webServer section of the web.config (see the attached sample application and the help topic Bart mentioned here).

    As for the rest of your web.config snippets -- it seems there is a missing dot (".") in the version string (Version=2011.2.712.40) and probably this triggers the more cryptic errors.


    Kind regards,
    Giuseppe
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now
  8. Ch4rl3s
    Ch4rl3s avatar
    1 posts
    Member since:
    Oct 2010

    Posted 13 Jan 2012 Link to this post

    I had the same error message and finally found my solution. I decided to post it here, knowing it's not the perfect place. But it may still help someone with the same situation.

    I use radgrid, and after upgrading it, it still worked on my deploy machine, but no longer in the test environment!
    After a LONG time of searching and implementing many suggestions, I found that on my productive/test environment, IIS7 was running in Classic mode. Switching it to Integrated and my "RadGrid-Portal" worked immediately.
Back to Top