Control Panel upgrade hangs

3 posts, 1 answers
  1. George
    George avatar
    87 posts
    Member since:
    Oct 2014

    Posted 04 Apr 2016 Link to this post

    Opening control panel I get a window that says:

    Old Telerik Control Panel Version - Hmmm. It seems this installer is a bit old. Please download the newest shiny version from here.

    "Here" is where it just sits there with little animation trying to open or download. I am using Google Chrome I have waited 2 hours so far, and will leave longer to see it anything ever happens. Tried a couple days ago with the same result for an hour.

    The good news, I won't have to renew and pay for Telerik anymore since I can't update it anymore with my historic couple-month-old Control Panel.  What is with Control Panel updating every time you use it anyway?

  2. Answer
    Yana avatar
    60 posts

    Posted 06 Apr 2016 Link to this post

    Hi George,

    Please accept our apologies for the inconvenience caused.

    Currently, we are experiencing an issue with the parameters of the URL we provide into the mentioned Control Panel's dialog. You can access the page without parameters on the following link. The problematic behavior is addressed to the development team which supports the web site and they are already working on it.

    We also have made some changes that blocked the update of Telerik Control Panel (the reason for the described message) but now everything should work as expected. However, I have attached file which contains the stand-alone installer of the Control Panel's latest version. 

    Could you please try to download it, unzip it, install it and let us know in case the issue still persists?

    I am looking forward to your feedback.

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
  3. George
    George avatar
    87 posts
    Member since:
    Oct 2014

    Posted 06 Apr 2016 in reply to Yana Link to this post

    The link to my account page with the download control panel button worked fine as did the .zip with the .msi installer in it.

    Hopefully, others that get the bad link see this post.



Back to Top