This is a migrated thread and some comments may be shown as answers.
content not showing in radwindow
2 Answers 86 Views
This is a migrated thread and some comments may be shown as answers.
Toad
Top achievements
Rank 1
Toad asked on 09 Feb 2012, 08:37 AM
i am using radwindow in user control which should open on click of button, if i use opernerElementID it does not open, if i use javascript
it does not show the controls which are to be inside rad window here is code

<%@ Control Language="C#" AutoEventWireup="true" CodeBehind="GridColumnSelector.ascx.cs" Inherits="GCSTestApplication.Controls.GridColumnSelector" %>
<%@ Register Assembly="Telerik.Web.UI" Namespace="Telerik.Web.UI" TagPrefix="telerik" %>
<script type="text/javascript">
    function showWin() {
 
        var rwManager = $find("<%= rWindow.ClientID %>");
        rwManager.show();
        return false;
    }
</script>
<telerik:RadButton ID="btnShowMenu" OnClientClicked="showWin" AutoPostBack="false" runat="server" Text="Show ">
</telerik:RadButton>
 
<telerik:RadWindowManager Behaviors="Close"  ID="rwm" runat="server">
<Windows>
<telerik:RadWindow ID="rWindow" ClientIDMode="Static" Title="Save layout" runat="server" Modal="true" Height="200" Width="400">
    <ContentTemplate>
        <asp:Label ID="Label1" runat="server" Text="Show some text" />
    </ContentTemplate>
</telerik:RadWindow>
</Windows>
</telerik:RadWindowManager>
please help me

2 Answers, 1 is accepted

Sort by
0
Accepted
Princy
Top achievements
Rank 1
answered on 09 Feb 2012, 10:42 AM
Hello,

This is the expected behavior when you are setting ClientIDMode as Static. Check the following forum thread which discussed similar scenario.
Changing window clientidmode to static causes JavaScript error

Thanks,
Princy.
0
Toad
Top achievements
Rank 1
answered on 09 Feb 2012, 11:13 AM
Thank you. u did solve my problem
Asked by
Toad
Top achievements
Rank 1
Answers by
Princy
Top achievements
Rank 1
Toad
Top achievements
Rank 1
Share this question
or