Compilation Error -Charts

Thread is closed for posting
4 posts, 1 answers
  1. ketan reddy
    ketan reddy avatar
    15 posts
    Member since:
    Nov 2008

    Posted 10 Feb 2009 Link to this post


    Hi,

    I deployed an old application (Which was probably using the older version of Telerik controls) on my system and was able to run it. After adding a few features, I noticed it was throwing the following error whenever i tried opening any of the Telerik charts. I tried reverting the changes and then debugging it but it doesnt solve the issue. It still throws me the error when i open a chart.

    Can Someone please tell me what might the issue be?


     Compiler Error Message: CS0433: The type 'Telerik.Charting.ChartSeriesType' exists in both 'c:\WINDOWS\assembly\GAC_MSIL\Telerik.Charting\2.0.5.0__d14f3dcc8e3e8763\Telerik.Charting.dll' and 'c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\root\4ae23f82\69cb7c0a\assembly\dl3\f587864b\0cd3bbc5_8e88c901\Telerik.Charting.DLL'




    Source Error:

    Line 240:     <asp:Panel ID="pnlChart" runat="server" Visible="false">
    Line 241:   <tr><td>
    Line 242:    <telerik:RadChart ID="RadChart2" runat="server" DefaultType="Pie" Width="710px">
    Line 243:</telerik:RadChart>
    Line 244:    </td></tr>



    Thanks,
    Ketan
  2. Answer
    Ves
    Admin
    Ves avatar
    2926 posts

    Posted 11 Feb 2009 Link to this post

    Hi ketan,

    it seems you have Telerik.Charting installed in the GAC (this used to be the default RadControls installer action for versions prior to Q3 2008) and you use it from the Bin folder as well. Please, keep only one of these -- either remove the one from Bin folder and make sure you have referenced the one in GAC and you use the correct version of Telerik.Web.UI or remove the reference to the one in GAC and use the one from the Bin folder.

    Sincerely,
    Ves
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  3. ketan reddy
    ketan reddy avatar
    15 posts
    Member since:
    Nov 2008

    Posted 11 Feb 2009 Link to this post

    Hello Ves,

    I tried removing the .dll file for the GAC alltogether. I wasnt able to as it said the windows installer was using it.  But then I was able to figure that out by making  a change in the registry.

    Also, I removed the reference to the GAC  and the application is up and running now. But I wonder how the whole issue came up in the firstplace since i dont remember making any major changes at all.

    Anyways thanks for the help. :-)

    -Ketan
  4. Jeff
    Jeff avatar
    16 posts
    Member since:
    May 2008

    Posted 25 May 2010 Link to this post

    Thanks for the information.  I was getting a similar error and after removing the charting dll from my bin folder, the chart displayed.
Back to Top