This is a migrated thread and some comments may be shown as answers.

Combobox loses it's styling

3 Answers 30 Views
ComboBox
This is a migrated thread and some comments may be shown as answers.
Gerry
Top achievements
Rank 1
Gerry asked on 02 Oct 2015, 04:29 PM

Hi,

I have a scenario where the combobox inside a update panel which resides inside a usercontrol loses it's styling on second display of the same usercontrol. I have created a project that reproduces the issue very easily. Doesn't appear to be browser specific as I have tried IE and Chrome.

I've taken my large project and scaled it down so it's easier to work with (sorry for the extra code):

Source Code

3 Answers, 1 is accepted

Sort by
0
Dimitar
Telerik team
answered on 07 Oct 2015, 11:02 AM
Hi,

When the project is further isolated, the issue becomes more obvious.

The problem is that the Save and Cancel buttons trigger postback when clicked. But your content page is in an update panel. There are two ways to overcome the issue - either trigger async postback on Save and Cancel, or do not use an update panel which holds the content page.

I am sending you the project further isolated.

Regards,
Dimitar
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
0
Gerry
Top achievements
Rank 1
answered on 07 Oct 2015, 04:39 PM

Dimitar,

So I applied your solution to my project. To make it work I had to make the triggers "ASYNC" and I had to move the Panel named "pnlHPRoom" inside the UpdatePanel ContentTemplate as you stated. This works BUT a full postback is required so that the parent usercontrol can update the data list with the new record or updated changes.

 

So what I did is call the update routine for the updatepanel on the masterpage inside my Hide() routine. I'm ok with this solution as it at least gets me working for now but I'm still curious as to why the control is failing to update it's styling on a full postback but not on a partial update.

0
Dimitar
Telerik team
answered on 09 Oct 2015, 11:44 AM
Hi,

I found another way to resolve the issue, which is described in our Troubleshooting documentation. You may check the following problem - "A control’s skin is not loaded after an AJAX update." - and its solution for further details.

Regards,
Dimitar
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
ComboBox
Asked by
Gerry
Top achievements
Rank 1
Answers by
Dimitar
Telerik team
Gerry
Top achievements
Rank 1
Share this question
or