This is a migrated thread and some comments may be shown as answers.

Columns appear hidden with scrolling

2 Answers 41 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Daniel
Top achievements
Rank 1
Daniel asked on 16 Jul 2010, 02:10 AM
Hi. I have several grids inside a multipage. The grids have scrolling enabled. I normally set all the columns to 1% with no wrapping and then set the column with the largest text in it to the remainder percentage. ie. 1%, 1%, 97%, 1%. This works fine with scrolling disabled. When I enable scrolling it looks like it is using the absolute size of 1% and is ignoring the text wrapping inside the header or column as all you can see is a pixel, probably the start of the text. This is a real pain, as some text looks really ugly when they wrap to the next line.

<telerik:RadGrid ID="rgActionRequests" runat="server" GridLines="None" OnNeedDataSource="rgActionRequests_OnNeedDataSource"
                                            AllowPaging="false" AllowSorting="false" Width="100%" BorderWidth="0">
                                            <MasterTableView AutoGenerateColumns="False" NoMasterRecordsText="<div style='padding: 10px;'>You have no action requests</div>">
                                                <Columns>
                                                    <telerik:GridTemplateColumn HeaderText="Request ID" UniqueName="ram_id" HeaderStyle-Width="1%"
                                                        ItemStyle-Width="1%" HeaderStyle-Wrap="false" ItemStyle-Wrap="false">
                                                        <ItemTemplate>
                                                            <a href="\\\\argus/Proclaim/CRM/PRODUCTION/crm<%#DataBinder.Eval(Container.DataItem, "ram_id")%>.vbs">
                                                                <%#DataBinder.Eval(Container.DataItem, "ram_id")%></a>
                                                        </ItemTemplate>
                                                    </telerik:GridTemplateColumn>
                                                    <telerik:GridBoundColumn DataField="descr" HeaderText="Details" UniqueName="descr"
                                                        HeaderStyle-Width="97%" ItemStyle-Width="97%">
                                                    </telerik:GridBoundColumn>
                                                    <telerik:GridBoundColumn DataField="date1" HeaderText="Received" UniqueName="date1"
                                                        HeaderStyle-Width="1%" ItemStyle-Width="1%" HeaderStyle-Wrap="false" ItemStyle-Wrap="false">
                                                    </telerik:GridBoundColumn>
                                                    <telerik:GridBoundColumn DataField="status" HeaderText="Status" UniqueName="status"
                                                        HeaderStyle-Width="1%" ItemStyle-Width="1%" HeaderStyle-Wrap="false" ItemStyle-Wrap="false">
                                                    </telerik:GridBoundColumn>
                                                </Columns>
                                            </MasterTableView><ClientSettings>
                                                <Scrolling UseStaticHeaders="true" AllowScroll="true" ScrollHeight="227px" SaveScrollPosition="true" />
                                            </ClientSettings>
                                        </telerik:RadGrid>

Something else I have noticed with scrolling and setting UseStaticHeaders to true, is that the line at the top of the scrollbar, between the scrollbar and header has been pushed up about 5 pixels. I have attached a screen of both issues. Thanks.

Daniel

2 Answers, 1 is accepted

Sort by
0
Accepted
Iana Tsolova
Telerik team
answered on 21 Jul 2010, 02:18 PM
Hello Daniel,

In order to overcome that issue I suggest that you either set the columns Width in pixels. Or set the MasterTableView Width, again in pixels to a large number so that there is enough space for the columns content to fit in.

Try it out and let me know if it makes any difference.

Sincerely yours,
Iana
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
0
Daniel
Top achievements
Rank 1
answered on 21 Jul 2010, 11:21 PM
Thanks for the reply Iana. I have changed the column widths to a larger percentage and look okay now. Thanks again.

Daniel
Tags
Grid
Asked by
Daniel
Top achievements
Rank 1
Answers by
Iana Tsolova
Telerik team
Daniel
Top achievements
Rank 1
Share this question
or