This is a migrated thread and some comments may be shown as answers.

Clicking on a checkbox in a big tree

3 Answers 58 Views
TreeView
This is a migrated thread and some comments may be shown as answers.
Jan
Top achievements
Rank 1
Jan asked on 16 Jul 2008, 01:09 PM
Hi,

I noticed a delay when I'm clicking on a checkbox in the treeview without any client-side script or server-side method. This issue arises only when there are a lot of nodes (I'm testing it with 400 nodes). When I want to check or uncheck a node for the first time it takes a while before it reacts. After the first time it's going a bit faster, but still slow. The checkbox changes first to a grey background and after a while it's checked.

A second issue I found is using a client-side script for childnode-checking. After a while Internet Explorer pops up with a message 'Stop running this script?'.

Can you help me to find a solution?

Kind regards,

Jan

3 Answers, 1 is accepted

Sort by
0
Accepted
Dimitar Milushev
Telerik team
answered on 22 Jul 2008, 04:54 PM
Hi Jan,

Please excuse me for the delayed response.

We have tested various scenarios similar to the one you describe - a flat tree with hundreds of nodes, a single node with hundreds of child nodes and different in-between versions. In all cases RadTreeView performs very well, without any noticeable delay when checking a single node. Could it be that there is something specific to your that we are missing in our tests? Are you using templates in your tests? It would be great if you can open a support ticket and send us the project you are testing so we can examine it locally.

As for the second issue, if your project has <compilation debug="true"> set in the web.config file, the ASP.NET AJAX framework will use debug versions of its scripts which are considerably slower that the production versions. These scripts can cause RadTreeView to perform significantly slower and it's possible that the Stop Script message is shown by Internet Explorer in this case. If you set <compilation debug="false"> in your web.config file, you should not see the message displayed for this number of nodes.

Sincerely yours,
Dimitar Milushev
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Jan
Top achievements
Rank 1
answered on 30 Jul 2008, 07:38 AM
Hi Dimitar,

Thanks for the reply. It did work with the setting in the web.config.

Jan
0
Ashok
Top achievements
Rank 1
answered on 20 Nov 2008, 06:58 AM
Hi Dimitar,

I am having the same problem as Jan. The tree is populated with 400 nodes.

I have set the scriptmode to release on the page & have also set the compilation debug = false in the web.config. I still end up getting the error.

Could you suggest a work-around ?

Warm Regards,

~ Ashok
Tags
TreeView
Asked by
Jan
Top achievements
Rank 1
Answers by
Dimitar Milushev
Telerik team
Jan
Top achievements
Rank 1
Ashok
Top achievements
Rank 1
Share this question
or