"Check All" feature is not working as expected with Load On Demand

1 Answer 65 Views
CheckBox ComboBox MultiSelect
chandi
Top achievements
Rank 1
chandi asked on 09 Dec 2021, 04:04 AM

My current version  - Telerik.Web.UI, Version=2021.1.330.45

I am using RadComboBox control and property EnableCheckAllItemsCheckBox="true". Therefore "Check All" feature enabled.

And other properties are as below

            EnableLoadOnDemand = true;
            ShowToggleImage = true; 
            ShowDropDownOnTextboxClick = true;
            ShowMoreResultsBox = true;
            ItemsPerRequest = 10;
            EnableVirtualScrolling = true;

steps are as follows.

1.  check "Check All" checkbox. Then first loaded 10 records got checked.

2. Then loaded another set of items clicking arrow icon at the bottom of the record list.

3. Loaded next 10 records and now all together showing 20 records. At this stage all checkboxes are unchecked but still "Check All" checkbox        is checked.

4. Unchecked "Check All" check box and and checked again. Now it is checked only last loaded 10 records only instead of 20 records.

I tried to resolve this by following code. But not luck.

Highly appreciate your quick response since this is urgent for me.

Thank You,

Chandi  

 

1 Answer, 1 is accepted

Sort by
0
Attila Antal
Telerik team
answered on 13 Dec 2021, 02:54 PM | edited on 13 Dec 2021, 02:55 PM

Hello Chandi,

I'm afraid that LoadOnDemand functionality combined with CheckBoxes is a Limitation of the ComboBox, see Limitations. A viable workaround would be to use RadMultiSelect with Virtualization as demonstrated in the MultiSelect->Virtualization

Regards,
Attila Antal
Progress Telerik

Love the Telerik and Kendo UI products and believe more people should try them? Invite a fellow developer to become a Progress customer and each of you can get a $50 Amazon gift voucher.

chandi
Top achievements
Rank 1
commented on 20 Jan 2022, 09:59 AM | edited

Hi Attila,

Thank you for your response.

I tried RadMultiSelect with Virtualization feature as demonstrated in document.

But when I enable virtualization it is not loaded data and showing console error.

Without following line it is loaded data.

<VirtualSettings ItemHeight="26" ValueMapper="valueMapper" />

Appreciate your help.

Thanks and regards,

Chandi


 

Attila Antal
Telerik team
commented on 21 Jan 2022, 10:19 AM

Hi Chandi,

Please submit a new thread in the MultiSelect Forum and share the current implementation you have so that we can investigate the problem.

I will close this thread for RadComboBox.

Tags
CheckBox ComboBox MultiSelect
Asked by
chandi
Top achievements
Rank 1
Answers by
Attila Antal
Telerik team
Share this question
or