Cannot see column being dragged in RadGrid grouping drag and drop

3 posts, 0 answers
  1. Niranjan
    Niranjan avatar
    2 posts
    Member since:
    Apr 2012

    Posted 02 Apr 2012 Link to this post

    I have a RadGrid built on lines of the demo - http://demos.telerik.com/aspnet-ajax/grid/examples/groupby/outlookstyle/defaultcs.aspx 
    Grouping and ungrouping works when I drag and drop, but I am not able to see the column being dragged when I attempt to drag a column to and from the GroupPanel. 

    Here are the relevant settings on my grid -

    <telerik:RadGrid ID="MyGrid" OnItemCreated="MyGrid_ItemCreated"  Skin="MySkin" EnableEmbeddedSkins="false" GridLines="None"  
                                                    OnNeedDataSource="MyGrid_NeedDataSource"  OnItemEvent="BudgetedChargesGrid_ItemEvent" OnItemDataBound="MyGrid_ItemDataBound"  
                                                     AllowMultiRowSelection="true" AllowMultiRowEdit="true" HorizontalAlign="Center" ShowStatusBar="false" AutoGenerateColumns="false" runat="server"
                                                     GroupingEnabled="true" ShowGroupPanel="true" ShowFooter="true"  EnableViewState="true" OnGroupsChanging="GroupsChanging" >
                                                    <ClientSettings AllowColumnsReorder="false" AllowDragToGroup="true">
                                                        <Scrolling AllowScroll="True" UseStaticHeaders="true" ScrollHeight="200px" />
                                                         <Selecting AllowRowSelect="true" UseClientSelectColumnOnly="false" EnableDragToSelectRows="false" />                          
                                                         <Resizing  AllowColumnResize="false" ClipCellContentOnResize="false" />
                                                         <ClientEvents OnGridCreated="AnaquaGrid_GridCreated" />
                                                    </ClientSettings>
                                                    <PagerStyle Mode="NextPrevNumericAndAdvanced" AlwaysVisible="true" />
                                                    <GroupingSettings RetainGroupFootersVisibility="true" ShowUnGroupButton="true"  />
                                                    <MasterTableView DataKeyNames="InvoiceBudgetId" Width="100%" ShowGroupFooter="true"  FooterStyle-CssClass="smallText strong"  GroupHeaderItemStyle-CssClass="smallText strong"  ItemStyle-VerticalAlign="Top"
                                                     AlternatingItemStyle-VerticalAlign="Top" HeaderStyle-VerticalAlign="Top" HeaderStyle-HorizontalAlign="Left"
                                                    CommandItemDisplay="None" Dir="LTR"  CurrentResetPageIndexAction="SetPageIndexToFirst" TableLayout="Auto" HierarchyLoadMode="Client" 
                                                    EnableColumnsViewState="false" EditMode="InPlace" AllowNaturalSort="false" AllowCustomSorting="true" AllowPaging="true" AllowSorting="true" AllowCustomPaging="true" >
      <SortExpressions>                                                  
                                                    </SortExpressions>
                                                       <Columns>
    <!-- I have GridBound and GridTemplate Columns here--!>
      </Columns>                                           
                                                    </MasterTableView>
                                                </telerik:RadGrid>

    Is there a setting to turn this on or is this built in with the grouping functionality? If latter, what is suppressing that functionality for me?
    Thanks,
    NP
  2. Niranjan
    Niranjan avatar
    2 posts
    Member since:
    Apr 2012

    Posted 03 Apr 2012 Link to this post

    Update for the benefit of other members. I found a solution to this. The problem was at my end. The z-index of the container of the grid was more than the grid itself.
  3. Raffee
    Raffee avatar
    1 posts
    Member since:
    Jul 2015

    Posted 06 Jul 2015 Link to this post

    This problem occurs when you have many layers on the page, some of which might override the default z-index of the grid CSS classes. the exact solution is to give the rgHeaderOver class a high z-index. e.g.:

     

    .rgHeaderOver
            {
            z-index: 1200 !important;
            }

Back to Top