Can't set z-index on radwindows

3 posts, 0 answers
  1. Raheel Ashraf
    Raheel Ashraf avatar
    13 posts
    Member since:
    Mar 2010

    Posted 28 Apr 2010 Link to this post

    I have some drop down menus (based on css and javascript) which I want to come over the radwindows.
    In previous version(2009_3_1208), this was working:

    <telerik:radwindowmanager runat="server"                              
                                style="z-index:0"

    However, in "Q1 2010" version, its not working. Also the z-index changed from 3000 to 100,000 :(
  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 29 Apr 2010 Link to this post

    Hello Raheel,

    Do you maximize the RadWindow? I am asking this because z-Index of 100 000 can happen only if the RadWindow is maximized. In such case we increase the index to ensure that it will be above all other DHTML elements on that page. Try setting ShowOnTopWhenMaximized to false and if this doesn't help - open a support ticket and send us a sample page that we could check.


    Kind regards,
    Georgi Tunev
    the Telerik team

    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
  3. Raheel Ashraf
    Raheel Ashraf avatar
    13 posts
    Member since:
    Mar 2010

    Posted 29 Sep 2010 Link to this post

    Hi,

    The issue was fixed using the ShowOnTopWhenMaximized flag. However, I noticed that if I hide the window and then show it again, it automatically adds a z-index:
    <div class="RadWindow RadWindow_Default  rwTransparentWindow rwMaximizedWindow" id="RadWindowWrapper_ctl00_Content_ctl00_OEC" style="z-index: 3002; position: absolute; width: 1122px; height: 1176px; visibility: visible; top: 176px; left: 3px;" unselectable="on" _behaviors="[object Object]" PopupBehavior="[object Object]">

    Initially the z-index in this div was 0.

    Thanks
Back to Top