BUG: RadWindow designer broken

9 posts, 0 answers
  1. Patrik Johansson
    Patrik Johansson avatar
    274 posts
    Member since:
    May 2010

    Posted 11 Apr 2011 Link to this post

    Following the latest release, the RadWindow designer seems broken. If you put a new RadWindow on a page, you get one chance to edit the contents template, the rest of the changes are visible in designmode, but not in sourcemode (ie never saved to the page). Very easy to reproduce, just drop a new RadWindow onto a page, go to edit Contents template, type "test", then do a return, type "test2" and this is what you will get when you save.

        <telerik:RadWindow ID="RadWindow1" runat="server">
            <ContentTemplate>
                test
            </ContentTemplate>
        </telerik:RadWindow>

    We are using latest release of Visual Studio 2010 SP1

    (For obvious reasons, it's hard to know if this is infact a bug in Visual Studio or the Telerik designer)
  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 11 Apr 2011 Link to this post

    Hi Patrik,

    Please accept our apologies for the temporary inconvenience. We are familiar with this problem and we are working on it - we will do our best to have it fixed for Q1 2011 SP2.


    Greetings,
    Georgi Tunev
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Patrik Johansson
    Patrik Johansson avatar
    274 posts
    Member since:
    May 2010

    Posted 11 Apr 2011 Link to this post

    This answer has us slightly worried. We consider this to be a serious bug and not a "temporary inconvenience" as the RadWindow designer is basically useless as it is now. There are ways to work around this issue by writing the markup code yourself but that is far from an optimal solution. Sorry, but the "we will do our best to have it fixed for Q1 2011 SP2" does not feel strong enough, this should be a "will definitely be fixed in Q1 2011 SP2 or earlier". Please consider putting this as a high priority bug.
  4. Ed Lance
    Ed Lance avatar
    61 posts
    Member since:
    Jun 2012

    Posted 13 Apr 2011 Link to this post

    I have to agree with Patrik.  I lost work because of this bug, which cost me time, which is of course, money in my business.  I will be editing from Source view from now on, but this needs to get fixed in the next release.
  5. Marin Bratanov
    Admin
    Marin Bratanov avatar
    5243 posts

    Posted 14 Apr 2011 Link to this post

    Hello,

    The RadWindow designer has been fixed in the latest release (Q1 2011 Service Pack 1).



    Regards,
    Marin
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

  6. Patrik Johansson
    Patrik Johansson avatar
    274 posts
    Member since:
    May 2010

    Posted 19 Mar 2012 Link to this post

    This bug seem to be back again in the latest version of Telerik (2012.1.215.40) :(

    Changes made in the designer will never make it to the markup in source view, exactly as before.
  7. Patrik Johansson
    Patrik Johansson avatar
    274 posts
    Member since:
    May 2010

    Posted 19 Mar 2012 Link to this post

    Actually, it seems that it may not be the same bug after all. In Visual Studio, it seems like it for some reason possible to edit the contents of the RadWindow in the designer without first choosing to Edit the Content Template. Like you can click on a label, and then change its text and it will look OK on screen, but no changes will be saved. However, if you first do the normal Edit Content Template, and do the same changes, it seem to work. So the bug here is really that it is, or at least appears to be, possible to change the contents without going into Edit Content Template first. 
  8. Marin Bratanov
    Admin
    Marin Bratanov avatar
    5243 posts

    Posted 20 Mar 2012 Link to this post

    Hello,

    After discussing the behavior in the support ticket I decided to post our findings here as well for anyone else that may have a similar problem.

    This second issue is not the same as the original. This case is related to control selection on the design surface - it is possible to select a control from the ContentTemplate and then if you start typing from the keyboard VS will change the shown text, but the markup will not be updated.

    This is not the correct way to modify the RadWindow's child controls - you must first select the Edit Templates link from the end of the smart tag and then you can edit the control (e.g. via their Properties menu or smart tag). Once this is done you should select the End Template Editing option from the smart tag of the RadWindow for the changes to take effect.


    Greetings,
    Marin
    the Telerik team
    If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
  9. Patrik Johansson
    Patrik Johansson avatar
    274 posts
    Member since:
    May 2010

    Posted 20 Mar 2012 Link to this post

    I can confirm Marins post, the workaround is to do the Edit Content Template first, which of course would seem logical as that is the way to edit most components, besides in this case, you can actually edit them anyway, but it won't make it all the way. One small correction though, you can basically edit any property of any selected control without being in edit mode. 
Back to Top