Blank page when printing RadWindow using Custom Button in IE 8

2 posts, 0 answers
  1. MarkMasson
    MarkMasson avatar
    4 posts
    Member since:
    Dec 2006

    Posted 23 Oct 2009 Link to this post

    Greetings!

    We were getting a blank page (nothing except headers and footers) when printing the contents of a RadWindow (for ASP.Net Ajax) using a Custom Button (according to the KB article: "Adding a Custom Button to RadWindow Titlebar") in IE 8.  Adding the following meta tag to the page referenced by the RadWindow solved the problem:

     

    <meta http-equiv="X-UA-Compatible" content="IE=7" /> 

     

     

     

    Insert the tag after the DOCTYPE declaration and just before the HTML Head section.

    The tag forces IE 8 to render the page in IE 7 compatibility mode.  We didn't experience this phenomenon when using other browsers.  Not sure exactly what caused IE 8 to print a blank first page.  So, please post a reply if you've experienced this and found an alternative solution.

    Hope this saves you time!

    Mark Masson
    Director of Technology
    Lucid Data Corporation
  2. Georgi Tunev
    Admin
    Georgi Tunev avatar
    7207 posts

    Posted 26 Oct 2009 Link to this post

    Hi Mark,

    If you are referring to this KB article, could you please open a support ticket and send me a small sample project where this issue could be reproduced? I am asking you this, because before posting this article we have tested it (I actually tested it again before replying here, just to play on the safe side) and everything is working as expected in IE8. Maybe there are some differences in your exact case that are causing this issue, but without examining it locally, we cannot be of much help.



    Kind regards,
    Georgi Tunev
    the Telerik team

    Instantly find answers to your questions on the new Telerik Support Portal.
    Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
Back to Top