Binaries only for netstandard2.0?

1 Answer 30 Views
General Discussions Installer and VS Extensions
Scott
Top achievements
Rank 1
Veteran
Scott asked on 06 Jul 2022, 08:50 PM | edited on 06 Jul 2022, 08:51 PM

The aspnet core binaries looked like this with the previous release. See below.

Now, it appears the net6.0 is gone.Why go backwards to netstandard2.0? Where was this explained? I feel like upgrading is a huge downgrade so I should NOT do it.

We were told this 2 years ago - https://visualstudiomagazine.com/articles/2020/09/16/net-standard-future.aspx .

Scott
Top achievements
Rank 1
Veteran
commented on 07 Jul 2022, 08:39 PM

As a paying customer, can I please get an official Telerik answer to this question?

1 Answer, 1 is accepted

Sort by
0
Stoyan
Telerik team
answered on 11 Jul 2022, 04:06 PM

Hi Scott,

This change has been done to keep the Telerik UI's source simple to maintain while retaining the support for the LTS .NET versions specified by Microsoft.

Although these versions are currently .NET 3.1 and .NET 6, .NET 5 is also supported by netstandard2.0. In this regard the only downgrade is that .NET 4.5.1 is no longer supported.

I hope the information above is useful. Please don't hesitate to contact me if more questions on the topic arise.

Regards,
Stoyan
Progress Telerik

The Premier Dev Conference is back! 

Coming to you live from Progress360 in-person or on your own time, DevReach for all. Register Today.


Scott
Top achievements
Rank 1
Veteran
commented on 11 Jul 2022, 04:28 PM

Ok, but do paying customers agree? I don't.  Were we asked?

Microsoft considers netstandard2.0 as something to move away from.  They have made that clear. Taking away net6.0 binaries is a huge mistake in judgement.

It will lead to one of 2 things: we do not upgrade or I attempt to compile net6.0 binaries myself.

Net5.0 is out of support. Net3.1 has been superseded by net6.0 and in a few month net7.0 will be out. This should matter to Telerik. The answer is to keep up, not go backwards. netstardard2.0 is not the answer to that.

Can Telerik reverse this bad decision in a future release or provide a download option now with the net6.0 binaries? The status quo is not acceptable.

If no, is it ok if paying customer compiles source into the correct DLLs?

Stoyan
Telerik team
commented on 12 Jul 2022, 05:17 PM

Hi Scott,

The Telerik UI for ASP .NET Core API is compatible with the current versions of .NET and we plan to keep it compatible with future versions.

I have reached out to our DevTeam and they have reaffirmed that the use of .netstandard2.0 in Telerik UI for ASP .NET Core's binaries ensures it is compatible with .NET 6.0 and the .NET 7.0 previews. 

That being said this does not limit you to use .netstandard in your applications. You can continue using .NET 6.0 as the targeted framework in your applications without interference.

Tags
General Discussions Installer and VS Extensions
Asked by
Scott
Top achievements
Rank 1
Veteran
Answers by
Stoyan
Telerik team
Share this question
or