This is a migrated thread and some comments may be shown as answers.

Background Color

2 Answers 170 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Guss
Top achievements
Rank 2
Guss asked on 11 May 2008, 09:48 AM
Hi, just for information.

I'm using the HTMLEditor in a rad grid.
The style
.radeditor.Vista.rade_wrapper table td.rade_contentCell 
    border: solid 1px #9db6c5; 
    background: white; 

controls the background color for the contant area, but in FF, my html background is actually shown the content area because the content background is either transparent or it inherits the background image from my html style, not the white background.

So by adding !important, this is fixed!
.radeditor.Vista.rade_wrapper table td.rade_contentCell 
    border: solid 1px #9db6c5; 
    background: white !important; 


2 Answers, 1 is accepted

Sort by
0
George
Telerik team
answered on 12 May 2008, 03:37 PM
Hi Guss,

Since the Editor ContentArea CSS styles are loaded first on purpose, it is possible for another global styles to override its settings. Hence if you want to prevent the overriding of the ContentAres CSS styles, just set the !important attribute after their values.

I hope this helps.

Sincerely,
George
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Matt
Top achievements
Rank 1
answered on 08 Aug 2008, 09:24 PM

A better solution would be adding the following to your editor

<CssFiles>
<telerik:EditorCssFile Value="~/App_Themes/Theme/Editor.Theme.css" />
</CssFiles>

Tags
Editor
Asked by
Guss
Top achievements
Rank 2
Answers by
George
Telerik team
Matt
Top achievements
Rank 1
Share this question
or