This is a migrated thread and some comments may be shown as answers.

AutoGenerateDeleteColumn

1 Answer 81 Views
Grid
This is a migrated thread and some comments may be shown as answers.
mww
Top achievements
Rank 1
mww asked on 31 Oct 2008, 03:44 PM
In my grid I have 

AutoGenerateDeleteColumn="True"

I also have 

 

<

 

 

Scrolling AllowScroll="True" UseStaticHeaders="True" />

 

Having AutoGenerateDeleteColumn set has stopped the grid from scrolling.  Also how do I get the delete column to appear on the left hand side of the grid instead of the right.

1 Answer, 1 is accepted

Sort by
0
Princy
Top achievements
Rank 2
answered on 03 Nov 2008, 05:47 AM
Hello Mark,

I tried setting AutoGenerateDeleteColumn to True with scrolling enabled at my end, but could not replicate your issue. Check out for the following points.
In order to display horizontal scroll for navigation, you need to make sure that the total width of the columns (either auto-generated or declaratively set) exceeds the width of the grid. Also, set the scroll height to display vertical scroll.

You can swap columns as shown below to change the positions of columns.
cs:
 protected void RadGrid1_PreRender(object sender, EventArgs e) 
    { 
        RadGrid1.MasterTableView.SwapColumns("FirstColumn", "AutoGeneratedDeleteColumn"); 
 
    } 

Thanks
Princy.
Tags
Grid
Asked by
mww
Top achievements
Rank 1
Answers by
Princy
Top achievements
Rank 2
Share this question
or