This is a migrated thread and some comments may be shown as answers.

Async FileUpload in ImageManager not working when using DBContentProvider

1 Answer 29 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Gareth
Top achievements
Rank 1
Gareth asked on 27 Oct 2015, 11:20 PM

Hi

I have put in place the DBContentProvider as per following link - http://www.telerik.com/support/code-library/connect-radfileexplorer-or-radeditor-to-a-sql-databse .

I can get the demo example shown in there working absolutely fine.  I put this into my application and while the postback upload method works ( with ImageManager.EnableAsyncUpload=false ), when set in AsyncMode it gets as far as uploading the file to temp directly, but then the "Upload" button in the dialog remains as disabled and never allows me to click it.

I am using the very latest version of the DLLs ( Telerik_UI_for_ASP.NET_AJAX_2015_3_1020_Dev_hotfix.zip ).  The DBContentProvider demo pages work fine with that.

With Fiddler, I can see a call being made to Telerik.Web.UI.WebResource.axd?type=rau and a response is made as follows:

 {"fileInfo":{"FileName":"​testfile.jpg","ContentType":"image/jpeg","ContentLength":146413,"DateJson":"2014-03-25T18:20:17.532Z","Index":0}, "metaData":"CS8S/Z0J/b2982DRxDin0BBslA7fI0cWMuWlPu4W3FmiPEsAWR/4iNPSediM81/ju6nCjgbBBl4x7K3JBvqbzisrT6LohPFoCytnaRo6CSbeerhhCjwXw42QKA9by33/7Yt4Z07spEc65GpCjpDI7muG/WyQE1L5+BBS4Ai9DWpOmwUeJT/KM/Zle2ETYBbAKMH2Q/gIBaVzmXo/Mx+iuktc03Dm6rk+J1dZscBrqDmg+6iDFCehh5I+dQb5gj8s32LSVE4qxnetDBvnUm2VHz6BfwXFHZATHA74lNyarPVqwO32X4BI+Ji9etWKWe9OD0Gwo27d3V5XLxXkDKaR1xmX1lncpx780EiB7G/Qc2nPBk+Tb/iyDl3jWXtkaNjFPZB30Jh43OwQQULzqrHVRbjbbdjfhYRD5hPJnUoYQSRL6Be6Fu8xN/WOJsK0wz9SXyl7znMFfNcjujCuhFkiTAVR6HBShN+K6/dE4FLsKMj3oKSuerpjRGVCFBKSuewdiIIAPTf0HLfvno6avil0kZU21dGG/LV48JVNRFVaFx5Q40HfikzrRR4Ayg3vPP6QNq+3nVxIxuuaH15I1ktL+g==" }​

I have checked permissions of that folder as best I can and ​tried giving full permissions for everything.   However it would seem to have enough permissions to write into the folder in the first place.  I have also tried debugging at all methods in my DBContentPRovider class, but it never gets in there.

 Any ideas?

 Thanks

 

1 Answer, 1 is accepted

Sort by
0
Vessy
Telerik team
answered on 28 Oct 2015, 02:34 PM
Hi Gareth,

I tested the content provider from the linked by you resource with enabled async upload, but everything behaved well on my side. I have made my test by modifying the following live demo, by enabling its async yploa functionality: FileExplorer - Custom File Content Provider. Can you download our live demos application and see whether it is working also on your side? 

Regards,
Vessy
Telerik
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Tags
Editor
Asked by
Gareth
Top achievements
Rank 1
Answers by
Vessy
Telerik team
Share this question
or