This is a migrated thread and some comments may be shown as answers.

ASP.NET AJAX Version?

3 Answers 82 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Rebecca Rasmussen
Top achievements
Rank 2
Rebecca Rasmussen asked on 04 Jun 2008, 05:24 PM
Basic question, and apologies if this in answered somewhere and I just missed it!

Which ASP.NET AJAX version(s) can be used with the RadControls for ASP.NET AJAX?

The fact sheet (http://www.telerik.com/support/requirements-and-compliance/system-requirements.aspx) states only that "It is a prerequisite to have ASP.NET AJAX installed when using Telerik RadControls for ASP.NET AJAX."

Currently ASP.NET AJAX is at 3.5?? I believe. Our company is still using the 1.0 version. I'd like to upgrade the control suite, but need to be sure it will fully function with the older AJAX version, or at least be aware of the item(s) that might not be functional in the older version so I can make an informed decision.

Thanks! :)

3 Answers, 1 is accepted

Sort by
0
Brad
Top achievements
Rank 1
answered on 05 Jun 2008, 04:10 AM
Hi Rebecca,

If you take a look at the directory where you installed the "RadControls for ASP.NET AJAX" you find two bin folders.  One is called "Bin35" the other just "Bin".  The "Bin35" folder is for 3.5 Framwork and latest version of AJAX and the "Bin" folder contains the reference files for the older version.

Cheers,
Brad
0
Rebecca Rasmussen
Top achievements
Rank 2
answered on 05 Jun 2008, 01:26 PM
Hi Brad,

Thanks. :)

But ... You state 'the "Bin" folder contains the reference files for the older version' ... singular: 'the older version'. There are at least two older versions ... 2.x and 1.x.

If the older version the control suite works with is 2.x, I'm out of luck so no sense installing.

If the controls will work with 1.x, then I'm good to go.

~Becca
0
Brad
Top achievements
Rank 1
answered on 05 Jun 2008, 11:43 PM
Hi Rebecca,

I have been working with 3.5 version since Visual Studio 2008 was released. From memory I skipped the 2.x AJAX release completely.  I think you will find that the version in the "Bin" folder will work with 1.x and 2.x, but I would need telerik to confirm that.

Regards,
Brad
Tags
General Discussions
Asked by
Rebecca Rasmussen
Top achievements
Rank 2
Answers by
Brad
Top achievements
Rank 1
Rebecca Rasmussen
Top achievements
Rank 2
Share this question
or