This is a migrated thread and some comments may be shown as answers.

ASP .NET 2.0 Web.Extension error despite web.config modification

0 Answers 112 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Hk
Top achievements
Rank 2
Hk asked on 20 Nov 2008, 09:37 AM
Hi,
I'm testing your ajax controls on ASP .NET 2.0 target framework.
I get the following error:

The type 'System.Web.UI.IScriptControl' is defined in an assembly that is not referenced. You must add a reference to assembly 'System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35'.

Despite the following changes:

1. I installed Microsoft .NET 2.0 AJAX extensions 1.0 and also Microsoft ASP .NET 2.0 AJAX Templates for VS 2008 from which I chose "New AJAX Web Application" and changed the target framework to 2.0.

2. I modified my web.config file to run AJAX from a tutorial I found on the web (http://asp.net/ajax/documentation/live/configuringASPNETAJAX.Aspx):
<?xml version="1.0"?> 
<configuration> 
  <configSections> 
    <sectionGroup name="system.web.extensions" 
        type="System.Web.Configuration.SystemWebExtensionsSectionGroup,  
        System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,  
        PublicKeyToken=31bf3856ad364e35"> 
      <sectionGroup name="scripting" 
        type="System.Web.Configuration.ScriptingSectionGroup,  
        System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,  
        PublicKeyToken=31bf3856ad364e35"> 
        <section name="scriptResourceHandler" 
          type="System.Web.Configuration.ScriptingScriptResourceHandlerSection,  
            System.Web.Extensions, Version=1.0.61025.0,  
            Culture=neutralPublicKeyToken=31bf3856ad364e35
          requirePermission="false" 
          allowDefinition="MachineToApplication"/> 
        <sectionGroup name="webServices" 
            type="System.Web.Configuration.ScriptingWebServicesSectionGroup,  
            System.Web.Extensions, Version=1.0.61025.0,  
            Culture=neutralPublicKeyToken=31bf3856ad364e35"> 
          <section name="jsonSerialization" 
              type="System.Web.Configuration.ScriptingJsonSerializationSection,  
              System.Web.Extensions, Version=1.0.61025.0,  
              Culture=neutralPublicKeyToken=31bf3856ad364e35
              requirePermission="false" allowDefinition="Everywhere" /> 
          <section name="profileService" 
              type="System.Web.Configuration.ScriptingProfileServiceSection,  
              System.Web.Extensions, Version=1.0.61025.0,  
              Culture=neutralPublicKeyToken=31bf3856ad364e35
              requirePermission="false" 
              allowDefinition="MachineToApplication" /> 
          <section name="authenticationService" 
              type="System.Web.Configuration.ScriptingAuthenticationServiceSection,  
              System.Web.Extensions, Version=1.0.61025.0,  
              Culture=neutralPublicKeyToken=31bf3856ad364e35
              requirePermission="false" 
              allowDefinition="MachineToApplication" /> 
        </sectionGroup> 
      </sectionGroup> 
    </sectionGroup> 
  </configSections> 
 
  <appSettings/> 
  <connectionStrings/> 
  <system.web> 
    <pages> 
      <controls> 
        <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> 
      </controls> 
    </pages> 
 
    <!--  
            Set compilation debug="true" to insert debugging  
            symbols into the compiled page. Because this  
            affects performance, set this value to true only  
            during development. 
        --> 
    <compilation> 
      <assemblies> 
        <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> 
      </assemblies> 
      <httpHandlers> 
        <remove verb="*" path="*.asmx"/> 
        <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> 
        <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> 
        <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/> 
      </httpHandlers> 
      <httpModules> 
        <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> 
      </httpModules> 
 
    </compilation> 
 
    <system.web.extensions> 
      <scripting> 
        <webServices> 
          <!-- Uncomment this line to customize maxJsonLength and add a  
         custom converter --> 
          <!-- 
      <jsonSerialization maxJsonLength="500"
        <converters> 
          <add name="ConvertMe"  
             type="Acme.SubAcme.ConvertMeTypeConverter"/> 
        </converters> 
      </jsonSerialization> 
      --> 
          <!-- Uncomment this line to enable the authentication service.  
           Include requireSSL="true" if appropriate. --> 
          <!--
      <authenticationService enabled="true" requireSSL = "true|false"/>
      --> 
 
          <!-- Uncomment these lines to enable the profile service. To  
           allow profile properties to be retrieved 
           and modified in ASP.NET AJAX applications, you need to add  
           each property name to the readAccessProperties and 
           writeAccessProperties attributes. --> 
          <!-- 
      <profileService enabled="true" 
        readAccessProperties="propertyname1,propertyname2" 
        writeAccessProperties="propertyname1,propertyname2" /> 
      --> 
        </webServices> 
        <!--  
    <scriptResourceHandler enableCompression="true"  
        enableCaching="true" /> 
    --> 
      </scripting> 
    </system.web.extensions> 
 
    <!-- 
            The <authentication> section enables configuration  
            of the security authentication mode used by  
            ASP.NET to identify an incoming user.  
        --> 
    <authentication mode="Windows"/> 
    <!-- 
            The <customErrors> section enables configuration  
            of what to do if/when an unhandled error occurs  
            during the execution of a request. Specifically,  
            it enables developers to configure html error pages  
            to be displayed in place of a error stack trace. 
 
        <customErrors mode="RemoteOnly" defaultRedirect="GenericErrorPage.htm"
            <error statusCode="403" redirect="NoAccess.htm" /> 
            <error statusCode="404" redirect="FileNotFound.htm" /> 
        </customErrors> 
        --> 
  </system.web> 
  <system.codedom> 
  </system.codedom> 
  <!--  
        The system.webServer section is required for running ASP.NET AJAX under Internet 
        Information Services 7.0.  It is not necessary for previous version of IIS. 
    --> 
  <system.webServer> 
    <validation validateIntegratedModeConfiguration="false" /> 
    <modules> 
      <add name="ScriptModule" 
        preCondition="integratedMode" 
        type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> 
    </modules> 
    <handlers> 
      <remove name="WebServiceHandlerFactory-ISAPI-2.0"/> 
      <add name="ScriptHandlerFactory" verb="*" path="*.asmx" 
        preCondition="integratedMode" 
        type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/> 
      <add name="ScriptHandlerFactoryAppServices" verb="*" 
        path="*_AppService.axd" preCondition="integratedMode" 
        type="System.Web.Script.Services.ScriptHandlerFactory,  
      System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,  
      PublicKeyToken=31bf3856ad364e35"/> 
      <add name="ScriptResource" preCondition="integratedMode" 
        verb="GET,HEAD" path="ScriptResource.axd" 
        type="System.Web.Handlers.ScriptResourceHandler,  
      System.Web.Extensions, Version=1.0.61025.0, Culture=neutral,  
      PublicKeyToken=31bf3856ad364e35/> 
    </handlers> 
  </system.webServer> 
</configuration> 
 


What should I do to make the controls compile?

Thanks,
Ensemble

No answers yet. Maybe you can help?

Tags
General Discussions
Asked by
Hk
Top achievements
Rank 2
Share this question
or