Angular 8 - Kendo

2 posts, 0 answers
  1. Mark
    Mark avatar
    2 posts
    Member since:
    Nov 2020

    Posted 23 Nov 2020 Link to this post

    This is my error message:

    ERROR in ./node_modules/@progress/kendo-angular-grid/dist/fesm2015/index.js 9465:29-35
    "export 'getter' was not found in '@progress/kendo-common'
    ERROR in ./node_modules/@progress/kendo-angular-grid/dist/fesm2015/index.js 9486:33-39
    "export 'getter' was not found in '@progress/kendo-common'
    ERROR in ./node_modules/@progress/kendo-angular-grid/dist/fesm2015/index.js 11538:26-32
    "export 'getter' was not found in '@progress/kendo-common'

    Partial of my package.json

    "@telerik/kendo-draggable": "^2.2.0",
    "@progress/kendo-angular-buttons": "^5.5.2",
    "@progress/kendo-angular-common": "1.2.3",
    "@progress/kendo-angular-dateinputs": "^4.4.0",
    "@progress/kendo-angular-dropdowns": "4.4.1",
    "@progress/kendo-angular-excel-export": "^3.1.6",
    "@progress/kendo-angular-grid": "4.8.2",
    "@progress/kendo-angular-inputs": "6.7.3",
    "@progress/kendo-angular-intl": "^2.0.4",
    "@progress/kendo-angular-l10n": "^2.0.3",
    "@progress/kendo-angular-pdf-export": "2.1.0",
    "@progress/kendo-angular-popup": "^3.0.7",
    "@progress/kendo-data-query": "^1.5.4",
    "@progress/kendo-drawing": "^1.9.3",
    "@progress/kendo-theme-default": "latest",
    "@progress/kendo-ui": "2020.3.1118",

    "webpack": "^4.42.1",

    I have done:

    npx npm-check-updates -u -f /.*@progress.*/ --packageFile projects/dino-spikes-lib/package.json

    npm install

     

    Any ideas?

     

  2. Mark
    Mark avatar
    2 posts
    Member since:
    Nov 2020

    Posted 26 Nov 2020 in reply to Mark Link to this post

    So after digging deeper - a lot deeper - I found a "solution" when using npm dedupe.

    It appears that @progress/kendo-angular-inputs@6.7.3 has a dependency of @progress/kendo-common@0.1.1 which is missing the getters.

    All other @progress components that depend upon @progress/kendo-common use at least 0.2.0

    I added @progress/kendo-common@0.2.1 to my root package.json dependency (so dedupe keeps 0.2.1 and not 0.1.1) and success.

     

Back to Top