Angular (Html) Viewer Icons Don't Show

3 posts, 0 answers
  1. Application
    Application avatar
    2 posts
    Member since:
    Nov 2013

    Posted 06 Aug Link to this post

    Has anyone ran into the situation where icon's don't render?  If I create an example application from scratch they load just fine.  However, when I incorporate all of the changes into our project (which is massive) they don't render.  Here is an example screenshot.  I'm not sure what to try next honestly.  I can't open a ticket as I can't send them a replicated project.  This is an Angular 7 frontend using the latest report viewer following all of their recommended steps.

     

     

    Thanks,
    -JV

     

  2. Application
    Application avatar
    2 posts
    Member since:
    Nov 2013

    Posted 06 Aug Link to this post

    I also attached what it looks like in Chrome.  The original image was taken from Edge.
  3. Silviya
    Admin
    Silviya avatar
    414 posts

    Posted 09 Aug Link to this post

    Hi JV,

    I could suggest to debug the page with the report viewer to see if there are any style rules that overwrite our font icons styles. For example, while I tested to reproduce the same behavior i just overwrite the font property of our fonticons.css - check this screen shot https://www.screencast.com/t/PeNaTnj8MNC

    I hope this would help you determine the cause. In case you cannot, send us the index.html page along with any additional stylesheets and scripts referred in the project.

    Best Regards,
    Silviya
    Progress Telerik
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Feedback Portal and vote to affect the priority of the items
Back to Top