This is a migrated thread and some comments may be shown as answers.

AjaxManagerProxy not finding controls in ContentPage

3 Answers 129 Views
Ajax
This is a migrated thread and some comments may be shown as answers.
Anthony
Top achievements
Rank 1
Anthony asked on 29 Dec 2007, 06:02 PM
Hello,
I have a site set up with a master page and context pages.  On the master page I have a script manager and rad ajax manager.  On the context page I have a script manager proxy and a rad ajax manager proxy.
The problem I'm having is when I click the "Configure Ajax Manager" link in design view, the resulting popup window does not display any of the content page's controls in the left panel.  The left panel has only a single checkbox named Controls.
The code I pasted below is a simple test I created that reproduces the problem. 
I've tried using the code-behind approach to register controls with the ajax manager at runtime, this works in the simple example, but generates many javascript errors when used in a complex environment.
I'm running Q3 2007 (trail) Prometheus on Vista x86 in Visual Studio 2008 with a project target of .net 3.5
I've had this issue since I started using Q3, either radcontrols of prometeus.  The web app worked perfectly with Q2.  Our license expired recently and I'm using the Q3 trail until I'm able to convince my employer it's worth renewing it.

Thank you for any help.

******* MasterPage *******

<%@ Master Language="C#" AutoEventWireup="true" CodeFile="MasterPage.master.cs" Inherits="MasterPage" %>

<%@ Register Assembly="Telerik.Web.UI, Version=2007.3.1218.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4"
    Namespace="Telerik.Web.UI" TagPrefix="telerik" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml">
<head runat="server">
    <title>Untitled Page</title>
</head>
<body>
    <form id="form1" runat="server">
    <asp:ScriptManager ID="ScriptManager1" runat="server">
    </asp:ScriptManager>
    <telerik:RadAjaxManager ID="RadAjaxManager1" runat="server">
    </telerik:RadAjaxManager>
    <div>
    <br />
        <asp:ContentPlaceHolder id="ContentPlaceHolder1" runat="server">
       
        </asp:ContentPlaceHolder>
    </div>
    </form>
</body>
</html>

***** Content Page ********
<%@ Page Language="C#" MasterPageFile="~/MasterPage.master" AutoEventWireup="true" CodeFile="Default.aspx.cs" Inherits="_Default" Title="Untitled Page" %>

<%@ Register Assembly="Telerik.Web.UI, Version=2007.3.1218.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4"
    Namespace="Telerik.Web.UI" TagPrefix="telerik" %>

<asp:Content ID="Content1" ContentPlaceHolderID="ContentPlaceHolder1" Runat="Server">
    <asp:ScriptManagerProxy ID="ScriptManagerProxy1" runat="server">
    </asp:ScriptManagerProxy>
    <telerik:RadAjaxManagerProxy ID="RadAjaxManagerProxy1" runat="server">
    </telerik:RadAjaxManagerProxy>
    <asp:Label ID="Label1" runat="server" Text="Label"></asp:Label>
<br />
<br />
    <asp:CheckBox ID="CheckBox1" runat="server" />
    <br />
    <asp:CheckBox ID="CheckBox2" runat="server" />
<br />
<br />
    <asp:Button ID="Button1" runat="server" Text="Button" onclick="Button1_Click" />
    <br />
    <br />
</asp:Content>

3 Answers, 1 is accepted

Sort by
0
Konstantin Petkov
Telerik team
answered on 02 Jan 2008, 01:03 PM
Hello Anthony,

Unfortunately this is a known design-time problem in VS 2008, which we were not able to resolve yet. I have to admit the issue is still present with the latest Q3 release with VS 2008 RTM as well. I hope we would be able to resolve it for future version of the products.

Meanwhile, please enter the necessary relation through the source. The IntelliSense makes that easy for coding.

Please, excuse us for the inconvenience this has caused.

Regards,
Konstantin Petkov
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
0
Sam
Top achievements
Rank 1
answered on 28 Apr 2008, 04:32 PM

Could you please let’s know if this issue has been resolved and when can we access the controls in design mode with the Ajax manager proxy.

 Thanks

0
Konstantin Petkov
Telerik team
answered on 29 Apr 2008, 11:58 AM
Hi Sam,

Unfortunately it appeared we cannot do anything in resolving this issue. You can read more about our findings in this blog post as well as in the forums here.

Kind regards,
Konstantin Petkov
the Telerik team

Instantly find answers to your questions at the new Telerik Support Center
Tags
Ajax
Asked by
Anthony
Top achievements
Rank 1
Answers by
Konstantin Petkov
Telerik team
Sam
Top achievements
Rank 1
Share this question
or