AJAX in Chrome Loses ToolTip

Thread is closed for posting
3 posts, 1 answers
  1. Baatezu
    Baatezu avatar
    110 posts
    Member since:
    Aug 2007

    Posted 10 Aug 2010 Link to this post

    I have a project [pretty much the same one my last 1/2 dozen posts have been on, hehe] where I have a chart in an ajax panel that, when refreshed the map isn't getting "reprocessed" and the old tool tips will still show. The chart is changing, so it's a whole new set of points and axis values, but if I mouse over the same place as the previous points, I get the previous tool tips appearing.
    This is only happening in chrome.

    I haven't had time to build a simple project to get it to work yet. Just wondering if there's any input or known issue with chrome and refreshing a chart's tooltip map.

    Thanks.
  2. Answer
    Giuseppe
    Admin
    Giuseppe avatar
    2363 posts

    Posted 12 Aug 2010 Link to this post

    Hello Baatezu,

    This is a bug in WebKit based browsers (like Chrome) working with ASP.NET AJAX update panels and image maps (RadChart renders an image map). This is already discussed in google forums:
    http://www.google.com/support/forum/p/Chrome/thread?tid=3d540ec401f9f53c&hl=en
    http://code.google.com/p/chromium/issues/detail?id=17203

    You can find the workaround in this help topic:
    Tooltips not updated with AJAX in Webkit browsers


    All the best,
    Freddie
    the Telerik team
    Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
  3. Baatezu
    Baatezu avatar
    110 posts
    Member since:
    Aug 2007

    Posted 12 Aug 2010 Link to this post

    I figured something like this had to be known about. :)

    That link worked great. Thanks.
Back to Top