This is a migrated thread and some comments may be shown as answers.

AdvancedFormTemplate viewstate?

2 Answers 55 Views
Scheduler
This is a migrated thread and some comments may be shown as answers.
Greg
Top achievements
Rank 1
Greg asked on 17 Oct 2008, 04:25 AM
I have been playing with the "Customizing the Advanced Template" example.  I have added another asp:linkbutton to the AdvancedEditForm.ascx with a blank CommandName as a way to initiate a postback that doesn't do an "Update" or "Cancel".  After the postback seems like the viewstate is gone.  The subject, description etc... are blank once the page reloads.  How do I maintain the viewstate across postbacks?

Thanks in advance,
--Greg

2 Answers, 1 is accepted

Sort by
0
T. Tsonev
Telerik team
answered on 17 Oct 2008, 07:23 AM
Hi Greg,

Thank you for reporting this issue. The problem occurs when the ViewState of the RadScheduler is turned off. We have since resolved the problem, but as part of the update of the advanced form for the Q3 release. You can either try turning the ViewState on, or take a look at the Q3 beta version that will be released later today. The new form has been much improved and the official release is due in about two weeks, so I recommend the latter. Sorry for the inconvenience.

All the best,
Tsvetomir Tsonev
the Telerik team

Check out Telerik Trainer, the state of the art learning tool for Telerik products.
0
Greg
Top achievements
Rank 1
answered on 17 Oct 2008, 07:37 PM
Thanks Tsvetomir.  I was able to get it to work with Q3 beta.
Tags
Scheduler
Asked by
Greg
Top achievements
Rank 1
Answers by
T. Tsonev
Telerik team
Greg
Top achievements
Rank 1
Share this question
or