This is a migrated thread and some comments may be shown as answers.

Administrator Privilege?

12 Answers 161 Views
Installer and VS Extensions
This is a migrated thread and some comments may be shown as answers.
Eric Schoenholzer
Top achievements
Rank 2
Eric Schoenholzer asked on 27 Nov 2009, 06:29 PM
When I try to start the VSX, there's a dialog to remind me that VS.NET should run with admin privileges.
I never develop with admin privilieges. Why needs the VSX adminisrtator privilieges?

Absolutly not useful. I don't see any reason why this is should be needed (unless for installing an update).

I got also an error when I check for the update:
"Error retrieving latest version information"

Thanks
Eric

12 Answers, 1 is accepted

Sort by
0
Erjan Gavalji
Telerik team
answered on 30 Nov 2009, 07:49 AM
Hi EricSch,

The administrative permissions request of the VSExtensions is due to their design - to operate correctly, the extensions need to locate the RadControls installations. They check the local registry to check that. When the IDE is started without administrative permissions (i.e. Run as administrator), the extensions do not have permissions to read the registry, hence the dialog we implemented.

We found recently that we have a logical error in the admin permissions check - we detect if the user is in the Administrators role, which is not correct. We are working on fixing this problem for the upcoming SP1 of RadControls. Please, bear with us some more.

Best regards,
Erjan Gavalji
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Eric Schoenholzer
Top achievements
Rank 2
answered on 30 Nov 2009, 12:11 PM
Hi,

Thanks for answering.
How I mentioned, I never develop with admin privileges. So your fix will not help.

Could you give a workaround for this problem?
For example, which registry keys do I need to give read permissions?

It makes no sense that I need admin privileges for configuring the web or the RAD controls.
So I would be happy, if you could change this behavior (elevating the privileges only for the upgrade process).

Thanks
Eric
0
Erjan Gavalji
Telerik team
answered on 30 Nov 2009, 02:30 PM
Hi EricSch,

The VSExtensions check the HKLM\Software\Telerik\ key and its subkeys. To my regret I cannot suggest a workaround right now. We will do our best to perform a better permission detection and possibly eliminate the need to restart the IDE.

As per the "Error retrieving latest version information" error (sorry for missing this the previous time), the VSExtensions make a call to a webservice set on the Telerik website. I'm not sure on the exact permissions the user you run Visual Studio has. Can you please, provide us with the permission set, so that we try reproducing the exact problem locally?

Kind regards,
Erjan Gavalji
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Eric Schoenholzer
Top achievements
Rank 2
answered on 30 Nov 2009, 10:44 PM
Hi,

Would be great if you provide a better user experience for the VSExtensions.
Right now I will not use them.

Because of the error:
I'm a normal domain user with no more or less rights.
To my local projects I have fulll access.

With "Fiddler" (Network tool), I see only that the connection to https://www.telerik.com is rejected.

Thanks
Eric
0
Erjan Gavalji
Telerik team
answered on 01 Dec 2009, 10:26 AM
Hi EricSch,

Thanks for the update, we'll do our best to have the permissions check fixed for the SP1 release (scheduled for the next week).

It is strange to have the https://www.telerik.com inaccessible. Can you contact your administrators for some help on the matter? Some details: we are using a secure connection for the service, holding the automatic updates, as the process involves user credentials transfer.

Kind regards,
Erjan Gavalji
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Eric Schoenholzer
Top achievements
Rank 2
answered on 01 Dec 2009, 01:13 PM
Hi Erjan,

The address  https://www.telerik.com is accessible, but shortly after the connection is closed.
So it's not a problem accessing the site. We also have no restriction in place.
When I use the address in the browser, I will redirected to HTTP.

And to avoid misunderstanding: 
When I check for the update, I have full administrator privileges. 

Eric
0
Erjan Gavalji
Telerik team
answered on 02 Dec 2009, 09:19 AM
Hi Eric,

The actual URL of the webservice is https://www.telerik.com/services/ProductVersion/Service.svc. Can you please, check if you could load this into your browser?

Could it be that some firewall setting has prevented the connection?

Best,
Erjan
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Erjan Gavalji
Telerik team
answered on 02 Dec 2009, 03:44 PM
Hi EricSch,

This is to notify you that we found an issue with the connection regarding the latest version checking on our side. We fixed it already and you should not get an error now.
There are no official releases yet (the VSExtensions still do not support upgrading to Latest Internal Builds), hence there are no newer versions available.

Kind regards,
Erjan Gavalji
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Eric Schoenholzer
Top achievements
Rank 2
answered on 03 Dec 2009, 12:07 AM
Yes, now I get the message: "Newer version check result: Not found.".
Seems to work.

Do I get any Telerik Points finding this error ;-) ?

thanks
Eric

0
Erjan Gavalji
Telerik team
answered on 03 Dec 2009, 07:42 AM
Hi Eric,

Yes, sorry for missing that! You were actually the first customer to report the problem!

Your Telerik account is updated accordingly.

Best,
Erjan Gavalji
the Telerik team

Instantly find answers to your questions on the new Telerik Support Portal.
Watch a video on how to optimize your support resource searches and check out more tips on the blogs.
0
Hidayet ÇELEN
Top achievements
Rank 1
answered on 22 Aug 2010, 04:23 PM
Hello ,

I have same problem .When I want to upgrade radcontrols for wpf using upgrade wizard , i have an error :

'Error retrieving latest version information.Please try again later or contact the Telerik team'.

Please can you help me?
0
Erjan Gavalji
Telerik team
answered on 23 Aug 2010, 01:07 PM
Hi Hidayet,

Can you please, give me some more information about the setup? Which Visual Studio version do you use?
Which version of RadControls for WPF do you have installed?

FYI, I just verified Visual Studio 2010 with Telerik WPF VSExtensions downloaded through the Online Gallery (v 2010.2.820.0) performs the download just as expected...

Kind regards,
Erjan Gavalji
the Telerik team
Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items
Tags
Installer and VS Extensions
Asked by
Eric Schoenholzer
Top achievements
Rank 2
Answers by
Erjan Gavalji
Telerik team
Eric Schoenholzer
Top achievements
Rank 2
Hidayet ÇELEN
Top achievements
Rank 1
Share this question
or