AddNewRecordText - ampersand problem

4 posts, 0 answers
  1. Kishan Gandikota
    Kishan Gandikota avatar
    44 posts
    Member since:
    Sep 2009

    Posted 04 Aug 2011 Link to this post


    I have telerik radgrid being used in the application with the add option also included in the grid. I added AddNewRecordText as "Add User & Employee" for add button. Please note that there is an ampersand in the text that was given. Now the "Add" button that appears on the grid shows the text correctly. However the tooltip for the button doesn't show up right. It encodes the ampersand symbol and shows it in the tooltip. Is there any workaround to fix this problem? 
    <telerik:RadGrid ID="testEdit" AllowMultiRowEdit="True" ShowFooter="false" ShowStatusBar="true"
                            runat="server" ShowHeader="false" AutoGenerateColumns="true">
                            <MasterTableView CommandItemDisplay="Top" InsertItemPageIndexAction="ShowItemOnCurrentPage">
                                <CommandItemSettings ShowRefreshButton="false" AddNewRecordText="Add User & Employee" />

    Kishan G K
  2. Shinu
    Shinu avatar
    17764 posts
    Member since:
    Mar 2007

    Posted 05 Aug 2011 Link to this post

    Hello Kishan,

    I tried the same scenario in this version 2011.1.315.35 and it worked as expected.
    I suppose it might be a version issue.So try upgrading to to the latest version with the help of the following documentation.
    Upgrading RadControls Trial to RadControls Developer license or newer version.

  3. Kishan Gandikota
    Kishan Gandikota avatar
    44 posts
    Member since:
    Sep 2009

    Posted 05 Aug 2011 Link to this post


    I am still seeing a bug with the telerik control.

    Here is my code:
    <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="WebForm4.aspx.cs" Inherits="WebApplication4.WebForm4" %>
    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "">
    <head runat="server">
        <form id="form1" runat="server">
            <telerik:RadScriptManager ID="RadScriptManager1" runat="server">
            <telerik:RadGrid ID="RadGrid1" runat="server" ShowHeader="true">
                <MasterTableView AutoGenerateColumns="False" CommandItemDisplay="Top" InsertItemPageIndexAction="ShowItemOnCurrentPage">
                    <CommandItemSettings AddNewRecordText="Add S&P" />
                        <telerik:GridButtonColumn ButtonType="LinkButton" UniqueName="EditCommandColumn"
                            CommandName="Edit" Text="Edit" />

    namespace WebApplication4
        public partial class WebForm4 : System.Web.UI.Page
            protected void Page_Load(object sender, EventArgs e)
                if (!IsPostBack)
                    RadGrid1.DataSource = new List<string>();

    Telerik version that i am using is: 2011.2.712.40.

    I believe this is the super latest version telerik has released it. Also, i have attached the screenshot of the problem. Let me know if i need to open a problem ticket for the same.

    Kishan G K
  4. Daniel
    Daniel avatar
    4949 posts

    Posted 11 Aug 2011 Link to this post

    Hello Kishan,

    We are aware of this problem. It will be fixed in the next official release of RadControls for ASP.NET AJAX which is expected around the midst of September.

    Best regards,
    the Telerik team

    Browse the vast support resources we have to jump start your development with RadControls for ASP.NET AJAX. See how to integrate our AJAX controls seamlessly in SharePoint 2007/2010 visiting our common SharePoint portal.

Back to Top