This is a migrated thread and some comments may be shown as answers.

Add New still shows on Batch Edit Mode?

1 Answer 25 Views
Grid
This is a migrated thread and some comments may be shown as answers.
Stefan
Top achievements
Rank 2
Stefan asked on 11 Jul 2013, 06:24 PM
I have AllowAutomaticInserts = false

but it still shows on the grid is it because I have editMode = Batch?

<telerik:RadGrid ID="dgGrid" runat="server"
            AllowAutomaticUpdates="True"
            AutoGenerateColumns="False"
            CellSpacing="0"
            GridLines="None"
            Skin="Sitefinity"
            Width="100%"
            AllowAutomaticDeletes="True"
            AllowAutomaticInserts="False">
            <ClientSettings>
                <Selecting AllowRowSelect="True" />
            </ClientSettings>
            <MasterTableView AllowNaturalSort="False" EditMode="Batch" BatchEditingSettings-OpenEditingEvent="DblClick">
                <BatchEditingSettings EditType="Cell" />
                <PagerStyle PageSizeControlType="RadComboBox" />
            </MasterTableView>
            <ItemStyle Wrap="False" />
        </telerik:RadGrid>


=================================== CODE

 

 

With dgGrid

 

 

 

'.MasterTableView.Columns.Add(editcolumn)

 

.MasterTableView.CommandItemDisplay =

 

GridCommandItemDisplay.Bottom

 

.MasterTableView.BatchEditingSettings.EditType =

 

GridBatchEditingType.Row

 

.MasterTableView.AllowAutomaticInserts =

 

False

 

 

 

End With

 



1 Answer, 1 is accepted

Sort by
0
Accepted
Princy
Top achievements
Rank 1
answered on 12 Jul 2013, 07:59 AM
Hi,

Please try setting the following code snippet.

ASPX:
<CommandItemSettings ShowAddNewRecordButton="false" />

OR

VB:
dgGrid.MasterTableView.CommandItemSettings.ShowAddNewRecordButton = False

Thanks,
Princy.
Tags
Grid
Asked by
Stefan
Top achievements
Rank 2
Answers by
Princy
Top achievements
Rank 1
Share this question
or