This is a migrated thread and some comments may be shown as answers.

Spell Check Handler Server Error:500

9 Answers 63 Views
Editor
This is a migrated thread and some comments may be shown as answers.
Sam
Top achievements
Rank 1
Sam asked on 25 Oct 2012, 09:48 PM
I have a rad Editor in the web form inside MVC razer project.  every thing work fine except when I click on Ajax spell Checker I receive this error: Spell Check Handler Server Error:500
and also on the find/replace button getting error:
Web.config registration missing!
 The Telerik dialogs require a HttpHandler registration in the web.config file. Please, use the control's Smart Tag to add the handler automatically, or see the help for more information: Controls > RadEditor > Dialogs > Introduction

it looks like not finding the handlers.
I have put the radSpell data files in App_Data

My web.config file is
<httpHandlers>
     <add path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" validate="false" />
     <add path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler" validate="false" />
     <add path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource" validate="false" />
   </httpHandlers>

<system.webServer>
      <add name="Telerik_Web_UI_SpellCheckHandler_axd" path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler" />
      <add name="Telerik_Web.UI_DialogHandler_aspx" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler" />
      <add name="Telerik_Web.UI_WebResource_axd" path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource" />
     </system.webServer>


any help would be appreciated


9 Answers, 1 is accepted

Sort by
0
Rumen
Telerik team
answered on 26 Oct 2012, 06:33 AM
Hi,

To enable the inline Ajax spellchecker of RadEditor, set the SpellCheckSettings-AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd" property, e.g.

<telerik:RadEditor ID="RadEditor1" Runat="server" DialogHandlerUrl="~/Telerik.Web.UI.DialogHandler.axd" SpellCheckSettings-AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd"></telerik:RadEditor>


Regards,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
0
Sam
Top achievements
Rank 1
answered on 26 Oct 2012, 04:05 PM

I have enabled the inline Ajax spellChecker of RadEditor as you mentioned but I am getting now this error

Web.config registration missing!
 The spellchecking functionality requires a HttpHandler registration in web.config. Please, use the control Smart Tag to add the handler automatically, or see the help for more information.

/Telerik.Web.UI.SpellCheckHandler.axd

and I have the web.config as I have explained above. it is look like not seeing the handler again.

0
Rumen
Telerik team
answered on 26 Oct 2012, 04:39 PM
Hello,

Try to remove the following property SpellCheckSettings-AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd". If the problem still persists set SpellCheckSettings-AjaxUrl="~/Telerik.Web.UI.SpellCheckHandler.axd" and test again.

Kind regards,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
0
Joe
Top achievements
Rank 2
answered on 03 Jul 2013, 02:07 PM
I have the same problem, RadEditor in MVC, and the RadEditor cannot find the SpellChecker resource after the RadEditor is rendered.
I have tried every combination:
<SpellCheckSettings AjaxUrl="/Telerik.Web.UI.SpellCheckHandler.axd"/>
<SpellCheckSettings AjaxUrl="Telerik.Web.UI.SpellCheckHandler.axd"/>
<SpellCheckSettings AjaxUrl="~/Telerik.Web.UI.SpellCheckHandler.axd"/>

and also not including this setting.
I also tried
<SpellCheckSettings AjaxUrl=@Url.Content("~/Telerik.Web.UI.SpellCheckHandler.axd")/>

My web.config has the perfect settings as recommended:
  <httpHandlers>
    <!--The <httpHandlers> tag is used when your ASP.NET MVC application is hosted in 
        IIS6, IIS7 in classic mode or Visual Studio's built-in web server.-->
    <add path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" verb="*" validate="false" />
    <add path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" verb="*" validate="false" />
    <add path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" verb="*" validate="false" />
    <add path="ScriptResource.axd" verb="GET,HEAD" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" validate="false" />
  </httpHandlers>
</system.web>
<system.webServer>
  <handlers>
    <!--The <handlers> tag is used when your ASP.NET MVC application is hosted in IIS7 integrated mode.-->
    <add name="Telerik_Web_UI_WebResource_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.WebResource.axd" type="Telerik.Web.UI.WebResource" />
    <add name="Telerik_Web_UI_SpellCheckHandler_axd" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.SpellCheckHandler.axd" type="Telerik.Web.UI.SpellCheckHandler" />
    <add name="Telerik_Web_UI_DialogHandler_aspx" verb="*" preCondition="integratedMode" path="Telerik.Web.UI.DialogHandler.axd" type="Telerik.Web.UI.DialogHandler" />
    <add name="ScriptResource" verb="GET,HEAD" preCondition="integratedMode" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35" />
  </handlers>

I am looking for new suggestions.
My next ideas are:
1. try to set the RadEditor SpellCheckerUrl from the javascript platform.
2. try adding a RadSpell control and a custom button and forget about the RadEditor embdeded spell checker.

Why is this so hard?

Joe





0
Ianko
Telerik team
answered on 03 Jul 2013, 03:27 PM
Hello Joseph,

Please check the original ticket, where the resolving of this issue is started. I have answered you there.
The solution is to put an additional ignore route like the code example bellow.
public static void RegisterRoutes(RouteCollection routes)
{
    routes.IgnoreRoute("{resource}.axd/{*pathInfo}");
    routes.IgnoreRoute("{*allaxd}", new { allaxd = @".*\.axd(/.*)?" });
    routes.MapRoute("UpdateJob", "Home/UpdateJob/jobId", new { controller = "Home", action = "UpdateJob", jobId = UrlParameter.Optional });
    routes.MapRoute("Default", "{controller}/{action}/{id}", new {
controller = "Home", action = "Index",
id = UrlParameter.Optional });
}

In addition for this example to work the AjaxUrl properties of the SpellCheckSettings must be removed.

Regards,
Ianko
Telerik
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to the blog feed now.
0
Sachita
Top achievements
Rank 1
Iron
Iron
Iron
answered on 14 Apr 2021, 02:37 PM

I have the same with Telerik R32020 with .NetFramework 4.8

Can anyone help where do we need to change settings or where can we find for spell checkers as with AJAXURL to change it ?

0
Rumen
Telerik team
answered on 14 Apr 2021, 04:00 PM

Hi Kumar,

The following KB article on the matter can be useful for solving the problem: https://docs.telerik.com/devtools/aspnet-ajax/knowledge-base/spell-error-web-config-registration-missing

 

Regards,
Rumen
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

0
Sachita
Top achievements
Rank 1
Iron
Iron
Iron
answered on 15 Apr 2021, 06:10 AM
Thanks for the help, issue is resolved
0
Rumen
Telerik team
answered on 15 Apr 2021, 07:21 AM

Thank you for your follow-up, Kumar! I am glad that everything is fine now!

 

Regards,
Rumen
Progress Telerik

Love the Telerik and Kendo UI products and believe more people should try them? Invite a fellow developer to become a Progress customer and each of you can get a $50 Amazon gift voucher.

Tags
Editor
Asked by
Sam
Top achievements
Rank 1
Answers by
Rumen
Telerik team
Sam
Top achievements
Rank 1
Joe
Top achievements
Rank 2
Ianko
Telerik team
Sachita
Top achievements
Rank 1
Iron
Iron
Iron
Share this question
or