This is a migrated thread and some comments may be shown as answers.
Editor lost spaces on paste
3 Answers 26 Views
This is a migrated thread and some comments may be shown as answers.
cglubish
Top achievements
Rank 2
cglubish asked on 10 May 2012, 09:23 PM
After upgrading to the recent build we have noticed a problem with spaces being stripped on paste (somewhat randomly)

We are able to duplicate the problem in our system AND on your demo.

Browser: Chrome 18.0.1025.168 m
Build: Telerik.Web.UI_2012_1_411_Dev_hotfix

If you paste the following content directly from a word doc (or Outlook email)

Lorem ipsum dolor sit amet, consectetur adipiscing elit. Donec elementum vehicula condimentum. Vivamus sed neque arcu. Proin mattis tristique ante, ac tincidunt sem vulputate sed. Vestibulum et elit ac lorem sagittis blandit a vitae dui. Sed aliquet fermentum pulvinar. Nunc erat ante, euismod sit amet blandit pulvinar, semper sed orci. Pellentesque egestas tempus magna, vitae interdum dui feugiat a. Duis a vestibulum arcu. Nam arcu turpis, fringilla in consectetur pulvinar, hendrerit sed sem. Phasellus id sem odio. Nam quis ante lectus. In non sapien vitae turpis pulvinar congue. Ut porta auctor nisl non hendrerit. Proin eget odio at nibh faucibus laoreet.


Some words lose the spaces between them.  For example "Donec elementum vehicula" goes to "Donec elementumvehicula"

Pasting into THIS editor (the forum) works fine.  Pasting into the demo (http://demos.telerik.com/aspnet-ajax/editor/examples/default/defaultcs.aspx) the problem exists.

The editor on the demo alerts me if I'd like to strip formatting. If I say yes, the problem exists.  If I say cancel, it pastes ok.

Reverting to the previous build in our app resolved the problem.  I notice it doesn't always occur depending on where I paste from.  But it can be duplicated every time by pasting from word. Its just pasting directly from Word into the demo editor.

Thanks for any input you can provide.

3 Answers, 1 is accepted

Sort by
0
Xander
Top achievements
Rank 1
answered on 11 May 2012, 03:22 PM
We are having the same issue!

Chrome and Firefox
0
Xander
Top achievements
Rank 1
answered on 11 May 2012, 03:42 PM
The issue exists in versions:
  • 2012.1.424.40
  • 2012.1.510.40


We just went back to version 2011.2.1108.35.
.
The issue is not in that version yet.
0
Rumen
Telerik team
answered on 15 May 2012, 09:03 AM
Hello guys,

I just answered to the other forum post on the subject: Editor lost spaces on paste.

Best regards,
Rumen
the Telerik team
If you want to get updates on new releases, tips and tricks and sneak peeks at our product labs directly from the developers working on the RadControls for ASP.NET AJAX, subscribe to their blog feed now.
Asked by
cglubish
Top achievements
Rank 2
Answers by
Xander
Top achievements
Rank 1
Rumen
Telerik team
Share this question
or