'Telerik' is undefined

47 posts, 0 answers
  1. DotNetGuy
    DotNetGuy avatar
    3 posts
    Member since:
    Jan 2008

    Posted 03 Jun 2008 Link to this post

    Wow ya im getting the same error.  I am indeed using IIS7 with windows vista.  The fix you just posted doesnt work for me.  the web.config file does not recognize the <handler> part under <system.webserver>.  Could you retype that if there was an error?

    I have this project loaded on:
    IIIS 5.1
    IIS 7
    ASP.NET Development Server (VS virtual server)

    It works on IIS 5.1 and ASP.NET Development Server but not on IIS7 for some reason.  Could this be the reason why it is not working?  Does Telerik support Vista yet?

    Thanks in advance
  2. Atanas Korchev
    Atanas Korchev avatar
    8462 posts

    Posted 04 Jun 2008 Link to this post

    Hello jerrod,

    RadControls for ASP.NET Ajax fully support Vista and IIS7. Please review this help topic for more info about HTTP handler registration.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  3. Louise Haugsted Knudsen
    Louise Haugsted Knudsen avatar
    2 posts
    Member since:
    Feb 2006

    Posted 13 Jun 2008 Link to this post

    Hello guyes.... I know this i an old post, but i just wanted to add a comment on why this problems can occour when you upgrade to the new IIS 7.0.

    I was running my site on IIS 6 and everything worked fine. But after installing Windows Server 2008 and thereby also IIS 7 i got this problem.

    I found out that my problem was caused by how the application pools act in IIS 7 by default.

    An application pool is set to run "Integrated" managed pipeline Mode. This causes this error to. From IIs manager you must switch over to Classic managed pipeline mode to get the telerik radmenu to work again!

    Hope this might help somebody if they encounter same problem as i did!

  4. Wardeaux
    Wardeaux avatar
    35 posts
    Member since:
    Aug 2006

    Posted 01 Jul 2008 Link to this post

     that was the trick... AppPool... sheez!! such an easy thing... such a pain to find!  THANKS so much!!
  5. Darren Hall
    Darren Hall avatar
    8 posts
    Member since:
    Apr 2007

    Posted 22 Jul 2008 Link to this post

    Please note that it is better to get your app running in integrated mode than to switch it back to classic mode (you can configure your app to do so much more such as applying ASP.NET forms authentication to non-asp.net requests like static files, classic ASP files, etc).

    To do so you just need to add the Telerik handlers to the <handlers> section of <system.webserver>, give them a 'name' attribute (it doesn't matter what), remove the 'validate="false"' attribute and add a preCondition="integratedMode" attribute.  You will need to do this for at least the webresource handler and if you use the telerik editor, also the spellcheckhandler and dialoghandler.

    e.g. you end up with

        <validation validateIntegratedModeConfiguration="false"/>  
          <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>  
          <remove name="WebServiceHandlerFactory-Integrated"/>  
          <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>  
          <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>  
          <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>  
          <add name="WebResource" path="Telerik.Web.UI.WebResource.axd" verb="*" type="Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=2008.1.619.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4" 
            preCondition="integratedMode" /> 
          <add name="SpellCheckHandler" path="Telerik.Web.UI.SpellCheckHandler.axd" verb="*" type="Telerik.Web.UI.SpellCheckHandler, Telerik.Web.UI, Version=2008.1.619.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4" 
          <add name="DialogHandler" path="Telerik.Web.UI.DialogHandler.aspx" verb="*" type="Telerik.Web.UI.DialogHandler, Telerik.Web.UI, Version=2008.1.619.20, Culture=neutral, PublicKeyToken=121fae78165ba3d4" 
          preCondition="integratedMode" /> 

    where the last three items are the handlers you have to add, the rest having been automatically added by Telerik (I don't know why the last three are not auto added!).

  6. Peter
    Peter avatar
    6637 posts

    Posted 22 Jul 2008 Link to this post

    Hello guys,

    Please check this new blog post which sheds more light on the discussed issue.

    the Telerik team

    Instantly find answers to your questions at the new Telerik Support Center
  7. Rolus
    Rolus avatar
    3 posts
    Member since:
    Jul 2006

    Posted 20 Aug 2008 Link to this post

    I had the same "telerik undefined" script error, using version 2008.2.723.35. After searching for a very longtime I found a radmultipage wich had the EnableEmbeddedScripts set to false. To prove my manager that was the only error causing the javascript error I built a simplewebsite containing 1 page.
    1 <%@ Page Language="C#" AutoEventWireup="true" CodeBehind="Default.aspx.cs" Inherits="WebApplication2._Default" %> 
    2 <%@ Register Assembly="Telerik.Web.UI, Version=2008.2.723.35, Culture=neutral, PublicKeyToken=121fae78165ba3d4" Namespace="Telerik.Web.UI" TagPrefix="telerik" %> 
    4 <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"> 
    6 <html xmlns="http://www.w3.org/1999/xhtml" > 
    7 <head runat="server">  
    8     <title>Untitled Page</title> 
    9 </head> 
    10 <body> 
    11     <form id="form1" runat="server">  
    12         <telerik:RadScriptManager ID="RadScriptManager1" runat="server" OutputCompression="AutoDetect">  
    13         </telerik:RadScriptManager> 
    14     <div> 
    17         <telerik:RadMultiPage ID="RadMultiPage1" runat="server" EnableEmbeddedScripts="false" RenderSelectedPageOnly="true" SelectedIndex="1">  
    18             <telerik:RadPageView ID="RadPageView1" runat="server">  
    19                 RadPageView 1  
    20             </telerik:RadPageView> 
    21             <telerik:RadPageView ID="RadPageView2" runat="server">  
    22                 RadPageView 2  
    23             </telerik:RadPageView> 
    24             <telerik:RadPageView ID="RadPageView3" runat="server">  
    25                 RadPageView 3  
    26             </telerik:RadPageView> 
    27         </telerik:RadMultiPage> 
    29     </div> 
    30     </form> 
    31 </body> 
    32 </html> 

    Maybe it saves someone time searching for a solution.
  8. Paul
    Paul avatar
    4281 posts

    Posted 21 Aug 2008 Link to this post

    Hi Rolus,

    By default JavaScript files are served as web resources (embedded in the Telerik.Web.UI.dll assembly).

    For custom deployment scenarios you can specify an alternative location for JavaScript files. To do so you should set the EnableEmbeddedScripts property to false. Then, the JavaScript files will not be loaded from the assembly.

    You will also need to add a script reference for each JavaScript file through the ScriptManager or RadScriptManager.

    A list of the JavaScript files used by RadMultiPage for ASP.NET AJAX can be found below. You need to register only the JavaScript files required by the controls you are currently using. Common JavaScript files (e.g. Core.js) should be registered only once.

     <telerik:RadScriptManager ID="RadScriptManager1" runat="server">  
            <asp:ScriptReference Path="~/Scripts/Common/Core.js" /> 
            <asp:ScriptReference Path="~/Scripts/TabStrip/MultiPage/RadMultiPageScripts.js" /> 

    All JavaScript files are available in the distribution (EXE, ZIP and hotfix) of RadControls' "Scripts" folder.

    Note that the order of the js files registered for most of RadControls is important since there are some dependencies between the javascript files of a single control. Therefore it is recommended to follow the exact order of the script references from the table below.

    All the best,
    the Telerik team

    Check out Telerik Trainer, the state of the art learning tool for Telerik products.
  9. Senthil
    Senthil avatar
    2 posts
    Member since:
    Sep 2008

    Posted 30 Sep 2008 Link to this post

    Dudes.. Its too silly but this is what in my case. Check the system date, and set it to current date! I do not really understand the things behind this, but it solved the prupose!
  10. Shamon Larson
    Shamon Larson avatar
    6 posts
    Member since:
    Mar 2008

    Posted 09 Jan 2009 Link to this post

    I tried nearly everyhing in this list to no avail. And it finally dawned on me to check my URLScan logs. The querystring length for the Telerik.Web.UI.WebResource.axd was too long. So I adjusted it and all is well.

    Just thought I'd post in case someone forgot like me.
  11. Larry
    Larry avatar
    24 posts
    Member since:
    Mar 2008

    Posted 29 Jan 2009 Link to this post

    I had a strange problem with users who must use Windows 2000 and IE6.  I wrote a web part that can create a control with multiple tab, multiple page, and multiple grid objects.  The web part can be bound to a SQL database tables and allows the user to perform CRUD (create, retrieve, update, and delete) operations.

    The web part works great on my test machine; which is a virtual machine with Windows 2003 Server, SQL Server 2005 and SharePoint 2007.  When I deploy the web part to my production SharePoint server, it also works greate with my Windows XP operating system and IE6.  (I know most of the software I mention is older, but not all corporations have moved to Vista.)

    Some of my users who have Windows 2000 were getting the error "Telerik is undefined" after navigating to the page that had the web part deployed on the page.  Not all of them, but enough to be problematic.  Those users that were having the problem, it was found that if they go to TOOLS --> INTERNET OPTIONS --> GENERAL tab and click the "Delete Files" under the Temporary Internet Files section, close down all browsers, open a browser and navigate back to the same page, the tabs, the grids, command item templates, and paging all work every time.  But how can you require that a user perform this action every time they navigate to the page?  Well, the answer is "you can't and shouldn't".

    Luckly, I have some bright users who enjoy tinkering.  One of them who was helping me test, clicked on the menu TOOLS --> INTERNET OPTIONS --> ADVANCED tab and just started reading all the options that were available on the ADVANCED tab.  He found one named "Do not save encrypted pages to disk".  He checked it, closed the browser, restarted a browser session, navigated to the page with the web part and it worked.  He closed the browser and navigated several more times to the page and it worked.  He found the problem.

    Now the funny part, my browser had the option unchecked and it worked every time.  The difference is I am using Windows XP and he is using Windows 2000.  We are both using IE6.  Apparently the browsers handle encrypted pages differently.  I should mention, that I discovered, by looking at the HTML source, that not all of the page was encrypted, just certain parts (I assume which are javascript for the Telerik product).  Because a certain part of the page is encrypted, I cannot tell what it is doing or what generated it.  But it must be cached and used the next time the user tries to open the page.

    Anyway, what solved my problem.  Just check this option "Do not save encrypted pages to disk" on Windows 2000 workstations, and the "Telerik is undefined" error goes away.

    By the way, I am using the 2008.1.515.35 version of the grid.
  12. Larry
    Larry avatar
    24 posts
    Member since:
    Mar 2008

    Posted 29 Jan 2009 Link to this post

    I was going crazy with this problem.  Look at my post at the bottom of the blog.  It may provide a clue.
  13. aabdan
    aabdan avatar
    26 posts
    Member since:
    Apr 2007

    Posted 11 Apr 2009 Link to this post

    Thank you very much Senthil
    now it is work (Telerik is Undefined)

    Best Wishes
    Ahmad Abdan
  14. Modern
    Modern avatar
    12 posts
    Member since:
    Mar 2009

    Posted 06 Nov 2009 Link to this post

    Thank you Senthi it was the datetime of my pc, but that\s so strange
  15. kevin
    kevin avatar
    1 posts
    Member since:
    Mar 2008

    Posted 04 May 2010 Link to this post

    Wow this helped. Just add Handler in Handler Mapping in IIS7

    Request Path



        Telerik.Web.UI.WebResource, Telerik.Web.UI, Version=(your version), Culture=neutral, PublicKeyToken=(from your web.config)



    Worked for me!

  16. TallOne
    TallOne avatar
    22 posts
    Member since:
    Aug 2009

    Posted 15 Sep 2010 Link to this post

    Thanks Senthil !  That was our issue as well! Unbelievable!
  17. Vina
    Vina avatar
    5 posts
    Member since:
    May 2011

    Posted 21 Sep 2011 Link to this post

    After long hours of searching and trying out stuff.. your's works!
    Apparently my web.config file is missing :

    <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    <add assembly="System.Drawing.Design, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    and missing;

    <remove verb="*" path="*.asmx"/>
    <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>
    <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>

    Once I put them in, the error is gone! Thanks again!
Back to Top