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Unable To Load Server Index For Source

ProductAuthor
Telerik UI for .NET MAUIDobrinka Yordanova

The trial-specific resources in this KB article are available for Telerik UI for .NET MAUI versions up to 2025 Q2. Starting with 2025 Q2, the resources for trial and commercial distributions were unified, and you must use the same resources (no "trial" in their name) regardless of whether you have a trial or commercial license.

Description

I see the error Unable to load the service index for source https://nuget.telerik.com/v3/index.json when trying to connect to the Telerik NuGet server.

Cause

This error Unable to load the service index for source https://nuget.telerik.com/v3/index.json doesn't indicate the exact cause of the problem. In such cases, check the additional error information, which usually provides an error code.

The most common reasons for connectivity issues with the Telerik NuGet server are related to:

  • Authentication and credentials.
  • Licensing—for example, requesting commercial packages with a trial license or vice-versa.
  • Missing or wrong configuration in the NuGet.Config file.
  • Network connectivity issues, including proxies and firewalls.

Solution

  • Verify that you can access the Telerik NuGet server and the expected packages: open the https://nuget.telerik.com/v3/search?q=maui&prerelease=true&skip=0&take=100&semVerLevel=2.0.0 URL directly in the web browser and enter your Telerik credentials in the prompt.

    • As a result, you will see a JSON output with the NuGet packages and versions that are available for you.

    • If the above URL doesn't open, you are facing either a network issue or the Telerik NuGet server is temporarily unavailable.

  • If the machine (PC or DevOps agent) is behind a proxy or a firewall, implement the required rules so you can access the NuGet server URL above.

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