This is a migrated thread and some comments may be shown as answers.

XAML designer issue

2 Answers 52 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Steffen
Top achievements
Rank 1
Veteran
Steffen asked on 02 Mar 2010, 10:35 AM
Hi,

some of my windows/usercontrols can not be loaded by the XAML-designer (VS 2008) anymore.
The following error shows up:

Could not load type 'Microsoft.Windows.Design.Metadata.ProvideMetadataAttribute' from assembly 'Microsoft.Windows.Design.Extensibility, Version=3.5.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a'.

When editing the XAML-code and deleting and adding empty lines sometimes(random?) the designer shows up again (for a short period of time).

Best Regards
Steffen

2 Answers, 1 is accepted

Sort by
0
Accepted
Boyan
Telerik team
answered on 05 Mar 2010, 10:22 AM
Hi Steffen,

Could you please specify which of Telerik controls are using this behavior. Is it related to a specific RadControl that breaks the design time.
Also could you try to rebuild the project and if this clears the error.

Greetings,
Boyan
the Telerik team

Do you want to have your say when we set our development plans? Do you want to know when a feature you care about is added or when a bug fixed? Explore the Telerik Public Issue Tracking system and vote to affect the priority of the items.
0
Steffen
Top achievements
Rank 1
Veteran
answered on 05 Mar 2010, 10:58 AM
Hi,

it is related to RadGridView. Rebuilding has no effect.
there's another thread about this in the RadGridView-forum: http://www.telerik.com/community/forums/wpf/gridview/issue-providemetadataattribute.aspx#1110966

I'm posting there now.

Best Regards
Steffen
Tags
General Discussions
Asked by
Steffen
Top achievements
Rank 1
Veteran
Answers by
Boyan
Telerik team
Steffen
Top achievements
Rank 1
Veteran
Share this question
or