WPF40 missing from latest Trial download

3 posts, 0 answers
  1. Buzz
    Buzz avatar
    36 posts
    Member since:
    Oct 2010

    Posted 18 Apr 2019 Link to this post

    I am reviving an application that must remain in Visual Studio 2010 and uses .NET 4.0.
    My projects all use Telerik's Binaries.NoXaml.

    I am renewing my license to use the latest Telerik release.
    While those wheels are in motion, I downloaded the latest trial and find there is no WPF40 folder in Binaries.NoXaml.
    I tried referencing the WPF45 dlls, but I'm getting build errors such as:
    The type reference cannot find a public type named 'RadButton'

    I'm not sure if this is because I'm referencing the WPF45 dlls or something else.
    I do see there is a WPF40 folder in the regular Binaries folder.
    This makes me question if the WPF40 Binaries.NoXaml are missing.

    Are they missing?
    Or should WPF45 work fine?
    I look forward to any advice.
    Buzz

  2. Vladimir Stoyanov
    Admin
    Vladimir Stoyanov avatar
    657 posts

    Posted 22 Apr 2019 Link to this post

    Hello Buzz,

    Firstly, please allow me to say that we are still deploying the 4.0 versions of the dlls along with the 4.5 versions in both Xaml and NoXaml.

    That said, may I ask you to share which file you downloaded from your telerik account? I tried downloading the "hotfix" .zip file containing the trial dlls, however on my end both the WPF40 and WPF45 folders were present in the Binaries.NoXaml folder. 

    Should you need any further assistance, may I ask you to send some pictures demonstrating the process that you are going through on your end? Additionally, can you share whether you are using the VS Extension for upgrading or for another purpose?

    I am looking forward to your reply.

    Regards,
    Vladimir Stoyanov
    Progress Telerik
    Get quickly onboarded and successful with your Telerik and/or Kendo UI products with the Virtual Classroom free technical training, available to all active customers. Learn More.
  3. Buzz
    Buzz avatar
    36 posts
    Member since:
    Oct 2010

    Posted 22 Apr 2019 in reply to Vladimir Stoyanov Link to this post

    I had downloaded the msi for the "New trial version" from my Downloads for Progress Telerik UI for WPF and installed.
    I just installed again and did Repair and WPF40 is there now.
    Maybe I mistakenly deleted it and didn't notice.
    I'm back on track.  Thanks Vladimir!

    Buzz


Back to Top