WPF ReportViewer not showing being displayed in design time or run time

2 posts, 0 answers
  1. Anthony
    Anthony avatar
    1 posts
    Member since:
    Oct 2014

    Posted 23 Oct 2014 Link to this post

    I'm attempting to use a ReportViewer to display reports in my WPF application. My first goal is to get a report viewer working in a new project to gain experience and then implement one in my main project. I've gone through a couple tutorials and have also run the example located at Telerik/Report Q2 2014/Examples/Csharp/WpfDemo. The example ran exactly the way it should and I had no problems with it at all. However when I use the same code in my own project it doesn't work. I don't get any errors or warnings and every builds correctly, but my window never displays the report viewer control. I stripped down the window in both the example and my project so there was only a window, a grid, and the report viewer. As expected the example still worked, but my code did not. I also tried removing all of my references to all telerik assemblies and using the ones used by the example. Nothing changed. Both my project and the example are using the same version of .NET and I cannot find anything different between the two projects. I have no idea what to do!
  2. KS
    KS avatar
    165 posts
    Member since:
    Oct 2012

    Posted 27 Oct 2014 in reply to Anthony Link to this post

    Hi,

    I believe the xaml files are not added or registered. Check this - Upgrade WPF Report Viewer to Q1 2014.

    -KS
Back to Top