why no fields available?

4 posts, 0 answers
  1. Adam
    Adam avatar
    4 posts
    Member since:
    Sep 2012

    Posted 25 Sep 2012 Link to this post

    I have a report bound to an ObjectDataSource, which is bound to a strongly-typed table adapter as suggested by "choose business object" dialog. (When I choose "data components only," the dialog suggests my table adapter--which makes sense.) The table adapter works--I see the data I expect when previewing the data in the DataSet designer.

    But my report is not seeing the available fields. I drop a text box on the report, go to its Value property and invoke the builder. The Fields node is empty. This happened in both my old version 4.x of Telerik Reporting and also the latest trial version I downloaded just now to see if it worked better.

    Am I missing something? I have done this successfully in the past with a SqlDataSource--that is get the fields come up to select. But the ObjectDataSource is not showing me any fields, so I'm stumped.
  2. Adam
    Adam avatar
    4 posts
    Member since:
    Sep 2012

    Posted 25 Sep 2012 Link to this post

    btw, I tried adapter queries both with and without parameters. I was thinking maybe that a parameter was not being supplied that prevented the field list from being resolved, but a parameterless query didn't help.
  3. Adam
    Adam avatar
    4 posts
    Member since:
    Sep 2012

    Posted 25 Sep 2012 Link to this post

    hold the phone -- I figured it out. Although I created the ODS correctly, I didn't actually assign it to the Report's DataSource property. After doing that, it worked as expected.
  4. Chandan Dey
    Chandan Dey avatar
    50 posts
    Member since:
    Aug 2012

    Posted 30 Jul 2014 Link to this post

    Hi,
    I found the solution.
    If anyone dose not get the fields in objectdatasource in expression.
    Then go to Visual Studio menu Telerik -> Report -> Data Explorer and you can get the all fields.
    After that you get all the fields in expression window fields node.

    Thanks
    Chandan
Back to Top