This is a migrated thread and some comments may be shown as answers.

[WebReportDesigner] Error when saving inline data in JsonDataSource

1 Answer 9 Views
General Discussions
This is a migrated thread and some comments may be shown as answers.
Jostein Stangeland
Top achievements
Rank 1
Jostein Stangeland asked on 12 Jan 2021, 02:07 PM

I'm using a JsonDataSource, InlineData, and I'm trying to edit/paste JSON in the data field. This is resulting in a 500-error stating that the parameter stream cannot be null. This only happens when I edit this data field. If I edit other parts of my report, everything is fine.

It seems like this is a front-end error, because if I set a breakpoint on the Save-function it seems to Base64-encode this field unless I try to edit it manually. If I paste in the data as Base64-encoded, it saves as normally and displays correctly upon refresh.

Is this a bug, or is there something wrong in my setup?

1 Answer, 1 is accepted

Sort by
0
Neli
Telerik team
answered on 15 Jan 2021, 12:28 PM

Hi Jostein,

I have tried to reproduce the issue but I am afraid I was not able to. Is it possible to send us a video that demonstrates the exact steps and the problem, so we can investigate it further? You can also send us the project that reproduces the problem.

I will be looking forward to receiving an update from you.

Regards,
Neli
Progress Telerik

Virtual Classroom, the free self-paced technical training that gets you up to speed with Telerik and Kendo UI products quickly just got a fresh new look + new and improved content including a brand new Blazor course! Check it out at https://learn.telerik.com/.

Tags
General Discussions
Asked by
Jostein Stangeland
Top achievements
Rank 1
Answers by
Neli
Telerik team
Share this question
or